このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

【ご質問】17-4 バーチャルドメイン設定の手順につきまして このメッセージに返信する
日時: 2008/10/05 18:11
名前: ruru
URL:
お世話になります。
掲題の手順について質問させていただきます。

(2)SMTP-AUTHのvpopmail対応の下記コマンドで、RPMを作成しようとすると以下のようなメッセージが現れました。
【コマンド】
rpmbuild -tb --clean courier-authlib-0.60.2.tar.bz2
【メッセージ】
openldap-devel は courier-authlib-0.60.2-1.i386 に必要とされています

そこで、yum -y install openldap-devel としたところ、以下のエラーが表示されてしまい先に進むことができません。
【エラー内容】
Error: Missing Dependency: openldap = 2.3.27-8.el5_1.3 is needed by package openldap-devel

解決策のご教示の程よろしくお願いいたします。

記事編集 編集

Page: | 1 | 2 |

Re: 【ご質問】17-4 バーチャルドメイン設定の手順につきまして このメッセージに返信する
日時: 2008/10/07 21:53
名前: ruru
URL:
ご回答いただきありがとうございます。

yum -y list '*ldap*'

にてopenldapをがインストールされていることを確認しました。

[メッセージ]

[root@ns1 ~]# yum -y list '*ldap*'
Loading "priorities" plugin
Loading "fastestmirror" plugin
Loading "downloadonly" plugin
Loading mirror speeds from cached hostfile
* rpmforge: apt.sw.be
* base: ftp.nara.wide.ad.jp
* updates: ftp.nara.wide.ad.jp
* addons: ftp.nara.wide.ad.jp
* extras: ftp.nara.wide.ad.jp
818 packages excluded due to repository priority protections
Installed Packages
nss_ldap.i386 253-13.el5_2.1 installed
openldap.i386 2.3.27-8.el5_2.4 installed
python-ldap.i386 2.2.0-2.1 installed
Available Packages
checkpassword-ldap.i386 0.01-1.2.el5.rf rpmforge
compat-openldap.i386 2.3.27_2.2.29-8.el5_1. base
cyrus-sasl-ldap.i386 2.1.22-4 base
ldapjdk.i386 4.18-2jpp.3.el5 base
ldapjdk-javadoc.i386 4.18-2jpp.3.el5 base
ldapvi.i386 1.7-1.el5.rf rpmforge
mod_authz_ldap.i386 0.26-8.el5 base
mozldap.i386 6.0.5-1.el5 base
mozldap-devel.i386 6.0.5-1.el5 base
mozldap-tools.i386 6.0.5-1.el5 base
nss_ldap.i386 253-12.el5 base
openldap.i386 2.3.27-8.el5_1.3 base
openldap-clients.i386 2.3.27-8.el5_1.3 base
openldap-devel.i386 2.3.27-8.el5_1.3 base
openldap-servers.i386 2.3.27-8.el5_1.3 base
openldap-servers-sql.i386 2.3.27-8.el5_1.3 base
pdns-backend-ldap.i386 2.9.21-4.el5.centos extras
perl-DBD-LDAP.noarch 0.09-1.el5.rf rpmforge
perl-Kolab-LDAP.noarch 1.02-1.2.el5.rf rpmforge
perl-Kolab-LDAP-Backend.noarch 1.01-1.2.el5.rf rpmforge
perl-Kolab-LDAP-Backend-ad.noarch 1.01-1.2.el5.rf rpmforge
perl-Kolab-LDAP-Backend-dirservd.noarch 1.01-1.2.el5.rf rpmforge
perl-Kolab-LDAP-Backend-slurpd.noarch 1.01-1.2.el5.rf rpmforge
perl-LDAP.noarch 1:0.33-3.fc6 base
perl-Lemonldap-NG-Handler.noarch 0.88-1.el5.rf rpmforge
perl-Lemonldap-NG-Manager.noarch 0.85-1.el5.rf rpmforge
perl-Mozilla-LDAP.i386 1.5.2-4.el5 base
perl-POE-Component-Client-LDAP.noarch 0.04-1.el5.rf rpmforge
php-ldap.i386 5.1.6-20.el5 base
proftpd-ldap.i386 1.3.1-1.el5.rf rpmforge
smbldap-tools.noarch 0.9.5-1.el5.rf rpmforge
wine-ldap.i386

しかし、yum -y install openldap-devel を実行すると 下記のように表示されてしまいます。

[メッセージ]

[root@ns1 ~]# yum -y install openldap-devel
Loading "priorities" plugin
Loading "fastestmirror" plugin
Loading "downloadonly" plugin
Loading mirror speeds from cached hostfile
* rpmforge: fr2.rpmfind.net
* base: ftp.nara.wide.ad.jp
* updates: ftp.nara.wide.ad.jp
* addons: ftp.nara.wide.ad.jp
* extras: ftp.nara.wide.ad.jp
818 packages excluded due to repository priority protections
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package openldap-devel.i386 0:2.3.27-8.el5_1.3 set to be updated
--> Processing Dependency: openldap = 2.3.27-8.el5_1.3 for package: openldap-devel
--> Finished Dependency Resolution
Error: Missing Dependency: openldap = 2.3.27-8.el5_1.3 is needed by package openldap-devel

何が原因なのでしょうか?
ご教授お願いいたします。



>>お世話になります。
>>掲題の手順について質問させていただきます。
>>
>>(2)SMTP-AUTHのvpopmail対応の下記コマンドで、RPMを作成しようとすると以下のようなメッセージが現れました。
>>【コマンド】
>>rpmbuild -tb --clean courier-authlib-0.60.2.tar.bz2
>>【メッセージ】
>>openldap-devel は courier-authlib-0.60.2-1.i386 に必要とされています
>>
>>そこで、yum -y install openldap-devel としたところ、以下のエラーが表示されてしまい先に進むことができません。
>>【エラー内容】
>>Error: Missing Dependency: openldap = 2.3.27-8.el5_1.3 is needed by package openldap-devel
>>
>>解決策のご教示の程よろしくお願いいたします。
>>
>>
>openldapを先にインストールします
>openldap openldap-devel 同時でも良いです
記事編集 編集
Re: 【ご質問】17-4 バーチャルドメイン設定の手順につきまして このメッセージに返信する
日時: 2008/10/08 08:32
名前: stranger
URL: http://ja.528p.com/
>ご回答いただきありがとうございます。
>
>yum -y list '*ldap*'
>
>にてopenldapをがインストールされていることを確認しました。
>
>[メッセージ]
>
>[root@ns1 ~]# yum -y list '*ldap*'
>Loading "priorities" plugin
>Loading "fastestmirror" plugin
>Loading "downloadonly" plugin
>Loading mirror speeds from cached hostfile
> * rpmforge: apt.sw.be
> * base: ftp.nara.wide.ad.jp
> * updates: ftp.nara.wide.ad.jp
>openldap-devel.i386 2.3.27-8.el5_1.3 base
>
>しかし、yum -y install openldap-devel を実行すると 下記のように表示されてしまいます。
>
>[メッセージ]
>
> * updates: ftp.nara.wide.ad.jp
>---> Package openldap-devel.i386 0:2.3.27-8.el5_1.3 set to be updated
>--> Processing Dependency: openldap = 2.3.27-8.el5_1.3 for package: openldap-devel
>--> Finished Dependency Resolution
>Error: Missing Dependency: openldap = 2.3.27-8.el5_1.3 is needed by package openldap-devel
>
>何が原因なのでしょうか?
>ご教授お願いいたします。

openldap-devel.i386 2.3.27-8.el5_2.4 がupdateにあるのですが
うまく検索されていないようです
アクセスできるダウンロードサイトから手動で落としてインストールしたらどうですか
記事編集 編集
Re: 【ご質問】17-4 バーチャルドメイン設定の手順につきまして このメッセージに返信する
日時: 2008/10/11 08:48
名前: ruru
URL:
stranger様

お世話になっております。

手動でインストールしたところ先に進むことができました!
ご教授いただきありがとうございます!
記事編集 編集

Page: | 1 | 2 |

件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -