このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

ドメインでアクセスするとルーターにつながる このメッセージに返信する
日時: 2008/07/09 18:42
名前: もにょ
URL:
こんにちわ。サイトに乗っているようにcentos5の設定をしています。設定したものは、
CentOS5インストール
>WindowsからSSHサーバーへリモート接続(Poderosaパスワード方式ログイン編)
>CentOS5初期設定ただし、メールサーバーのOP25B対策がわからずroot宛メールを転送設定はしていません
>Perlモジュールパッケージ管理システム導入(cpan2rpm)
>rootkit検知ツール導入(chkrootkit) >
>アンチウィルスソフト導入(Clam AntiVirus)
>ドメイン名取得(ieServer.Net編)
>DNSサーバー構築(BIND)(内部向け)これだけはhttp://vine.1-max.net/bind.htmlをコピペで設定しました
>Webサーバー構築(Apache)…というところで止まってしまいました。どうぞよろしくお願いします。

タイトルにあるように、ドメインでアクセスするとルーターに接続してしまいます。
ルーターはNTTの【PR-200NE】です。NTTにサーバーを立てるために80番ポートを開く設定について聞き、静的IPマスカレード設定で設定するようにと言われ、192.168.1.2(サーバー機のローカルIP)に設定しましたがダメで、【PR-200NE】で検索し、他サイトなどでパケットフィルタ設定をしていたのでやってみましたがダメでした。
ドメインは【無料・ダイナミックDNS(DDNS)サービス - ieServer.Net】で、取り、DICEの設定もしましたが…
WebSitePulseのテストツールで、Website Testをすると401エラーがでます(ルーターにアクセスなのでパスを求められるからだと思います)

NTTに【ルーターに接続される】と言っても、最終的にプロバイダの方で〜と言われ、プロバイダの方では、知識のある方が〜とか言われ、設定方法は教えられないといわれ・・・

ログは何を出せばいいのか検討もつきませんが(コマンドも良く理解してませんが)、どうぞお力を貸してください。よろしくおねがいします。
記事編集 編集

Page: | 1 | 2 |

Re: ドメインでアクセスするとルーターにつながる このメッセージに返信する
日時: 2008/07/10 21:17
名前: aki
URL:
もにょ様


ん〜?別におかしくないですね。


ファイアウォールとSELinuxはどうなってますか?

おっと
/etc/resolv.confがサーバーのローカルIPアドレスになっていればルーターの
IPアドレスに戻して下さい。
記事編集 編集
Re: ドメインでアクセスするとルーターにつながる このメッセージに返信する
日時: 2008/07/10 23:08
名前: もにょ
URL:
>aki様

SELinuxはgetenforceで確認した所Disabledとなっているので無効になってるようです。

ファイアウォールというのはiptablesを使うやつでしょうか。それは設定していないので入ってないと思います。あと、インストールするときか何かのときにファイアーウォールの設定画面がでましたが、特に設定しなかったはず・・・けれど不安に思い、分かる限りで設定ファイルを開いてみましたがこんな記述です。


# Firewall configuration written by system-config-securitylevel
# Manual customization of this file is not recommended.
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
:RH-Firewall-1-INPUT - [0:0]
-A INPUT -j RH-Firewall-1-INPUT
-A FORWARD -j RH-Firewall-1-INPUT
-A RH-Firewall-1-INPUT -i lo -j ACCEPT
-A RH-Firewall-1-INPUT -p icmp --icmp-type any -j ACCEPT
-A RH-Firewall-1-INPUT -p 50 -j ACCEPT
-A RH-Firewall-1-INPUT -p 51 -j ACCEPT
-A RH-Firewall-1-INPUT -p udp --dport 5353 -d 224.0.0.251 -j ACCEPT
-A RH-Firewall-1-INPUT -p udp -m udp --dport 631 -j ACCEPT
-A RH-Firewall-1-INPUT -p tcp -m tcp --dport 631 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
-A RH-Firewall-1-INPUT -j REJECT --reject-with icmp-host-prohibited
COMMIT

もしや80番ポートが入ってない=許可されてない・・・のかしら。
一応/etc/init.d/iptables stop で止められるようなので、止めてみましたが相変わらずでした。

これで何か原因が分かればいいのですが・・・(;_;)

※追記※とりあえず、ファイアーウォールの設定も後々必要そうなので設定してみましたが、なにも変化ナシです(+_+)
記事編集 編集
Re: ドメインでアクセスするとルーターにつながる このメッセージに返信する
日時: 2008/07/11 09:13
名前: aki
URL:
もにょ様

nmap localhost もしくは nmap 192.168.1.2の結果はどうですか?
インストールされていない場合 yum -y install nmap でインストールして下さい。
記事編集 編集
Re: ドメインでアクセスするとルーターにつながる このメッセージに返信する
日時: 2008/07/11 09:46
名前: もにょ
URL:
>aki様
おはようございます。返信ありがとうございます。

nmapがはいっていないようなのでインストールしました。その結果・・・

nmap localhost では、以下のような情報が。
Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2008-07-11 09:35 JST
Interesting ports on localhost.localdomain (127.0.0.1):
Not shown: 1668 closed ports
PORT STATE SERVICE
22/tcp open ssh
25/tcp open smtp
53/tcp open domain
111/tcp open rpcbind
135/tcp filtered msrpc
137/tcp filtered netbios-ns
138/tcp filtered netbios-dgm
139/tcp filtered netbios-ssn
445/tcp filtered microsoft-ds
631/tcp open ipp
694/tcp open unknown
953/tcp open rndc


80ポートをあけているのがUDPなので、nmap -sU localhostでUDPのほうもやってみました。
Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2008-07-11 09:36 JST
Interesting ports on localhost.localdomain (127.0.0.1):
Not shown: 1481 closed ports
PORT STATE SERVICE
53/udp open|filtered domain
111/udp open|filtered rpcbind
631/udp open|filtered unknown
688/udp open|filtered unknown
691/udp open|filtered unknown
32768/udp open|filtered omad

Nmap finished: 1 IP address (1 host up) scanned in 1.380 seconds


nmap 192.168.1.2の結果
Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2008-07-11 09:38 JST
Interesting ports on 192.168.1.2:
Not shown: 1677 closed ports
PORT STATE SERVICE
22/tcp open ssh
111/tcp open rpcbind
694/tcp open unknown

Nmap finished: 1 IP address (1 host up) scanned in 0.172 seconds


UDPの方もnmap -sU 192.168.1.2でやってみました。
Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2008-07-11 09:39 JST
Interesting ports on 192.168.1.2:
Not shown: 1481 closed ports
PORT STATE SERVICE
53/udp open|filtered domain
111/udp open|filtered rpcbind
631/udp open|filtered unknown
688/udp open|filtered unknown
691/udp open|filtered unknown
32768/udp open|filtered omad

Nmap finished: 1 IP address (1 host up) scanned in 1.417 seconds

・・・よくわからないけれど、80ポートが開いてない・・・感じ?サーバーのポートが開いてなかったということなのかしら。

上記のみですがよろしくおねがいします。自分でもちょっとポートの開け方とか調べてみます。
記事編集 編集
Re: ドメインでアクセスするとルーターにつながる このメッセージに返信する
日時: 2008/07/11 10:55
名前: aki
URL:
もにょ様

80が閉まってますね。

デフォルトのファイアウォールは止めて、こちらのサイト様のhttp://centossrv.com/iptables.shtml
を使用された方が早いかと思います。

とりあえずローカルIPアドレスでwebにアクセスできるよう頑張って下さい。
記事編集 編集
Re: ドメインでアクセスするとルーターにつながる このメッセージに返信する
日時: 2008/07/11 13:46
名前: もにょ
URL:
>aki様

iptablesで設定をしても同じ結果が返ってきました。

ふと思い出した事が・・・

CentOSをはじめてインストールしたときに、PCのローカルIPがわからなかったので、自動取得にしてやったんですね。http://centossrv.com/centos5.shtmlの9.インターフェイスeth0設定 と10.ホスト名、ゲートウェイ、DNS設定を飛ばしたようなかんじで。
その時は、別のPCで192.168.1.2へ飛ぶとhtmlテストページには飛べて、ドメインからはルーターに繋がるという結果はドメインにかんしては同じでしたが、ローカルIPでは見れていたんです。

が、その後いろいろやっていたらローカルIPが変わってしまったらしく、XP機からアクセスできなくなったので、ローカルIPを固定させてOS再インストールしてみたのですが、今度はこの有様。

そこで、DHCPを自動取得にすべくコマンドを検索したけれど見つからず。
これはOS再インストールでなんとかなるからいいとして、ローカルIPがころころ変わるのをなんとかせねば。けれどルーターにそれらしき項目がない。
以前モデム=LAN=ルーター=LAN=PC という接続の時はルーターに接続されているPCとかも見られて、割り振られたIPとか、固定にするPCとかも設定できたんだけど・・・もしやルーター変えないといけない、とか?

いや、まさかそんなことはないはず。きっと設定方法がなにかあるはず!と、今いろいろ調べ中です。

ごめんなさい、ぐるぐるとしてしまって(;_;)
とりあえず今現在こんな状況です。
記事編集 編集
Re: ドメインでアクセスするとルーターにつながる このメッセージに返信する
日時: 2008/07/11 18:08
名前: aki
URL:
もにょ様

OSインストール時に手動でIPアドレスを指定すれば後々、変わる事はありませんので
ルーターは関係ありません。

一応、サーバーでifconfigの内容、クライアントのコマンドプロンプトで
ipconfig /allの内容を教えて下さい。
記事編集 編集
Re: ドメインでアクセスするとルーターにつながる このメッセージに返信する
日時: 2008/07/11 19:15
名前: もにょ
URL:
現状報告です。

※追記※
>aki様
すみません、現状のテキストをまとめるのに手間取ってる間に返信があったなんて。とりあえず今はこんな状況で、解決が見えたようなかんじになっております。
※追記終了※


再インストールをしてDHCPを自動取得にしてGUIでも起動できるようにし、初期設定とPerlモジュールパッケージ管理システム導入(cpan2rpm) とWebサーバー構築(Apache)だけやってみました。ら・・・

あっさり行きました(^^;)

原因はDHCPをCENTOS側で固定した事、だったようです。
けれどこれだとローカルIPが動いてしまう可能性がありますよね。一応ルーターの方にDHCP手動設定なるものがあったので、やってみましたが、大丈夫か不安。
一応、http://www.websitepulse.com/かな?そこでテストしてみたところ、一応OKとでました。が、アドレス直打ちでみるとしばらく読み込んでエラーが出る状況なのですが、ここでDNSサーバー構築(BIND) の登場、でいいのでしょうか。

セキュリティ関連も入れてないので一つずつインストールしてみてちゃんとアクセスできるか確認していきます。

また結果報告に参りますが、aki様親身に返答していただき本当にありがとうございます。自分ではおかしい所がなんなのか検討もつきませんでしたし(;_;)
では、とりあえずセキュリティとBIND設定やってきます。
記事編集 編集
Re: ドメインでアクセスするとルーターにつながる このメッセージに返信する
日時: 2008/07/11 20:57
名前: aki
URL:
もにょ様

ルーターで自動割当てにしておいても問題ないですよ。
クライアントの数が増えた際に面倒です。

非固定IP環境でのDNSサーバーは内部だけの事なので設定しなくても問題ありません。
設定すれば内部でもドメイン名でサーバーにアクセスできるってだけの物です。

まぁ、全く役にたちませんでしたが、ご勘弁を

頑張って下さい。
記事編集 編集
Re: ドメインでアクセスするとルーターにつながる このメッセージに返信する
日時: 2008/07/12 00:47
名前: もにょ
URL:

結果報告に参りました。

結果として、BINDもしっかり投入してドメインで見れました(^_^)

aki様本当にありがとうございました。aki様の【>http://192.168.1.2でテストページ等が表示できないのであればドメイン名でも無理】という言葉と、【ローカルIPアドレスでwebにアクセスできるように】という言葉で、DHCP設定の事を思い出しましたし。
役にたたなかったなんてとんでもない!誰か(というかaki様)がいればそれだけで心強かったです。ひとりだと絶対くじけてました。

手探りの私にしっかりと対応してくださってホント感謝です。
ルーター名で検索しても設定方法こそのってはいるものの、PCのDHCP自動取得の事など乗っていなかったのと(見落としてた可能性もありますが)、このサイトにIPを固定すると記載されているから、原因だとは全く思いつきませんでした。

ではでは、この辺で失礼します。暑かったり肌寒かったり、冷房病、熱中症と心配なことがたくさんな季節ですのでお体にお気をつけてお過ごしください。

どうも本当にありがとうございました。
記事編集 編集

Page: | 1 | 2 |

件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -