このスレッドは未解決です(解決したらこちらで解決済にしてください)
<<戻る

VMware内のCentOSに構築したrouterについて このメッセージに返信する
日時: 2008/04/27 23:24
名前: Object
URL:
Fedoraで自宅サーバー構築サイト内の記事、"Linuxサーバーをルーターにする PCルーター構築(PPPoE+iptables)"を参考に、VMware内にインストールしたCentOSにrouterを構築しました。

VMwareが起動しているOS(WIndowsXP)からWANに接続することは可能です。

しかし、上記PCに接続した他PCはWANに接続することができません。

(ブラウザ上からは、Internet Explorer ではこのページは表示できませんと表示されます。)

どこが原因なのか、部位を特定できない状態です。

解決方法をご存じの方がいらっしゃいましたら、教えていただけないでしょうか。

■現在確認した点

・VMware起動PCに対し、他PCからPingを打っても応答がない
・VMware起動PC自身が、自NICに対し行ったPingはすべて応答する(NIC1,NIC2,仮想NIC1)

※提供している情報が少なすぎると自分でも思いますが、どのような情報を提供してよいのかわからないためです。
※指摘していただければ、逐次提供させて頂きます。
記事編集 編集
Re: VMware内のCentOSに構築したrouterについて このメッセージに返信する
日時: 2008/04/28 12:27
名前: ZED
URL:
vmware-config.pl時にnatで構成しました?ブリッジで構成しました?

ブリッジにしてしまうとhostに飛んでしまうので、natで構成・・・
XPからは接続できるようなので、これ位しか思いつかないです・・・


ちなみにうちでは
hostと仮想5台で構成しています。それぞれブリッジ接続で〜す
記事編集 編集
Re: VMware内のCentOSに構築したrouterについて このメッセージに返信する
日時: 2008/04/28 20:28
名前: Object
URL:
ZEDさん

返信ありがとうございます。

ブリッジで構成しておりました。
natで再構成し、問題が解決するか試してみます。
記事編集 編集
Re: VMware内のCentOSに構築したrouterについて このメッセージに返信する
日時: 2008/04/28 21:03
名前: Object
URL:
自己レスです。

natで仮想NICを構築してみたところ、CHAP認証が成功しなくなり、WANに接続できなくなってしまいました。

natで仮想NICを構築する場合の注意事項等、教えていただければ幸いです。

>ZEDさん
>
>返信ありがとうございます。
>
>ブリッジで構成しておりました。
>natで再構成し、問題が解決するか試してみます。
>
記事編集 編集
Re: VMware内のCentOSに構築したrouterについて このメッセージに返信する
日時: 2008/04/29 07:55
名前: ZED
URL:
NATで構築した際は、ホストをルーター・ファイアーウォール+GATWAYにしてしまって、
DHCPで振ってあげると簡単です。
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -