このスレッドは未解決です(解決したらこちらで解決済にしてください)
<<戻る

Clam AntiVirusインストール このメッセージに返信する
日時: 2008/04/17 12:34
名前: あき
URL:
[root@centos ~]# yum -y --enablerepo=rpmforge install clamd

を実行しますと

Error: Missing Dependency: libclamunrar_iface.so.3 is needed by package clamav

が表示されインストールされません 回避方法をご存じのかた よろしくお願いします。
記事編集 編集
Re: Clam AntiVirusインストール このメッセージに返信する
日時: 2008/04/17 14:55
名前: よしぞう
URL:
>[root@centos ~]# yum -y --enablerepo=rpmforge install clamd
>
>を実行しますと
>
>Error: Missing Dependency: libclamunrar_iface.so.3 is needed by package clamav
>
>が表示されインストールされません 回避方法をご存じのかた よろしくお願いします。


その症状は、私のupdateの症状と同じです。 http://centossrv.com/patio/patio.cgi?mode=view&no=760

新規でインストールする場合、

yum -y --enablerepo=rpmforge install clamd.i386 0.91.2-1.el5.rf
と、バージョンを指定してインストールすればいいと思いますよ。
その前に、 yum clean all を2回と yum --enablerepo=rpmforge clean all を実行してから、インストールして下さい。
記事編集 編集
Re: Clam AntiVirusインストール このメッセージに返信する
日時: 2008/04/17 15:52
名前: ZED
URL:
>よしぞうさん

GJです!
ただ・・・

yum -y --enablerepo=rpmforge install clamd.i386 0.91.2-1.el5.rf
ではなく
yum -y --enablerepo=rpmforge install clamd-0.92.1-1.el5.rf
でOKだと・・・(^^;)
記事編集 編集
Re: Clam AntiVirusインストール このメッセージに返信する
日時: 2008/04/18 11:40
名前: よしぞう
URL:
もう、clamAVの最新版がリリースされておりますので
yum -y --enablerepo=rpmforge install clamd

で、大丈夫ですよ。
ただ、/etc/clamd.conf の300行目をコメントアウトしないとエラーが出ると思います。

ちなみに、古いバージョンのclamdをインストール済みの場合は

yum -y --enablerepo=rpmforge update clamd

ですからね。(^_^)
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -