このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

Webサーバー確認 このメッセージに返信する
日時: 2008/04/10 12:44
名前: ビスケット
URL:

この間に引き続き、早速のつまずき&毎度の初歩的な質問ですいません!

今日はWebサーバー構築をやってみているのですが、設定はうまくいったように思っていたのに、Webページ表示確認は「こちらのページはただいま準備中です。」となり、それ以降のSSI確認等は「ページが見つかりません」となります。

設定では、

LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined

LogFormat "%h %l %u %t \"%!414r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined

この部分は、私が見ている画面が「\」が逆向きスラッシュになってたり、文字が違ったりがあって、「!」ももしかしたら違うのかも…とか思って付け足せませんでした。だからそのままにしています。


この文字が違う中でやってること自体が変にしていってるんでしょうか?

原因がどこにあるかもわからない状態ですが…、何かしら助言していただけたらと思います。

本当にいつもすいません・・・。
記事編集 編集
Re: Webサーバー確認 このメッセージに返信する
日時: 2008/04/10 16:13
名前: aki
URL:
windowsで表示される『\』はlinuxではバックスラッシュになります。
『!』は!です(^^)
記事編集 編集
Re: Webサーバー確認 このメッセージに返信する
日時: 2008/04/25 16:16
名前: ビスケット
URL:
akiさんご教授ありがとうございました!!

しかし、まだできずにいます・・・。
IPアドレスでなら見ることができたので、「IPアドレスの自動更新」あたりの設定がうまく行ってないのかな?と試行錯誤中です。

何の設定がいけないんでしょうか・・・。
記事編集 編集
Re: Webサーバー確認 このメッセージに返信する
日時: 2008/04/26 22:28
名前: aki
URL:
>IPアドレスでなら見ることができたので、「IPアドレスの自動更新」あたりの設定がうまく行ってない>のかな?と試行錯誤中です。

>何の設定がいけないんでしょうか・・・。

と言われましても、どのような環境でどのような事を行われたのか判らないので
何が駄目なのか判断できません。
記事編集 編集
Re: Webサーバー確認 このメッセージに返信する
日時: 2008/04/28 09:41
名前: Un Poco
URL:
IP アドレスの自動更新ということは、動的 DNS サービスを利用されているということでしょうか。
そうであれば、現在の IP アドレスが反映されているか否か (~自動更新がきちんと働いているかどうか) は、そのサービスにログインすれば確認できませんか。
当て推量も数を打てば当たる理屈ですが、的を絞ることを考えたほうが早いと思います。
記事編集 編集
Re: Webサーバー確認 このメッセージに返信する
日時: 2008/04/28 11:17
名前: ビスケット
URL:

akiさん、UnPocoさん

こんな私に対応していただき、本当にありがとうございますm(__)m
別方の助言により、私のPCで自サーバーを見れるように設定していなかったというのがわかりましたので、どうにかここはクリアし、自分のPCからテストページを見ることができました!!自分が間抜けでしょうがありません…。
しかし、一応形はできてたんだ、とすっきりしました。
次の壁として、自宅に帰り、自宅のPCから見ると開けないという状況でしたので、次は外から見れない原因に取り組みたいと思います!
akiさん、UnPocoさんにご指摘いただいたように、しっかり的を絞っていけるように、知識もがんばってつけていきます!ありがとうございました。
記事編集 編集
Re: Webサーバー確認 このメッセージに返信する
日時: 2008/05/09 18:21
名前: ビスケット
URL:

見てる方が多いようなので、同じような状況の方がいらっしゃるのかなと思いましたので、私がやった自サーバーを見れる設定を念のため参考程度に。

使用しているクライアント機で
マイコンピュータ→C:ドライブ→system32→drivers→etc→hosts(テキストか何かで開く)



127.0.0.1 lokalhost

この最終行に
192.168.XXX.XXX yyyy.com(自サーバーのローカルIP ホスト名)
を書き込めば見れました。
(コマンドプロンプト使ってもっとすばやくできるやり方もあると思います)

他にも、サーバー側にも同じように設定をするやり方もあるみたいです。
vi /etc/hosts

皆さん、四苦八苦しながらも助け合い頑張りましょう!
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -