このスレッドは未解決です(解決したらこちらで解決済にしてください)
<<戻る

AWStatsにて集計結果が出ない このメッセージに返信する
日時: 2008/03/02 21:16
名前: 吉田
URL:

いつもお世話になっております。

当方、CentOS4.6にて
貴サイトのリファレンスに従い、AWStatsをインストールいたしました。
しかし、/var/www/awstatsreport/にアクセスしても
肝心のログ集計結果が表示されず、
観覧アクセス、月・日別などの集計が0、その他UAやホスト集計もまったく出てこない状態です。

awstatsinit.shをかけなおしたところ、
リファレンスの例にある表示結果のような表示はされず、

---------
reate/Update database for config "/etc/awstats/awstats.ホスト.conf" by AWStats version 6.7 (build 1.892)
From data in log file "/var/log/httpd/access_log.4"...
Phase 1 : First bypass old records, searching new record...
Searching new records from beginning of log file...
AWStats did not find any valid log lines that match your LogFormat parameter, in the 50th first non commented lines read of your log.
Your log file /var/log/httpd/access_log.4 must have a bad format or LogFormat parameter setup does not match this format.
Your AWStats LogFormat parameter is:
1
This means each line in your web server log file need to have "combined log format" like this:
111.22.33.44 - - [10/Jan/2001:02:14:14 +0200] "GET / HTTP/1.1" 200 1234 "リファラ" "Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)"
And this is an example of records AWStats found in your log file (the record number 50 in your log):
リファラ - - [20/Jan/2008:10:30:39 +0900] "-" 200 16804 "-" "Snoopy v1.2.3"
Setup ('/etc/awstats/awstats.ホスト.conf' file, web server or permissions) may be wrong.
Check config file, permissions and AWStats documentation (in 'docs' directory).
Create/Update database for config "/etc/awstats/awstats.ホスト.conf" by AWStats version 6.7 (build 1.892)
From data in log file "/var/log/httpd/access_log.3"...
Phase 1 : First bypass old records, searching new record...
Searching new records from beginning of log file...
AWStats did not find any valid log lines that match your LogFormat parameter, in the 50th first non commented lines read of your log.
Your log file /var/log/httpd/access_log.3 must have a bad format or LogFormat parameter setup does not match this format.
Your AWStats LogFormat parameter is:
1
---------

以下のような形で出てきてしまいます。

エラーらしきものが出てこなかったので、
./awstatsreport.sh ホスト /var/www/awstatsreport
を実行しましたところ
HTMLは作ってくれるのですが
最後に
「mv: cannot stat /グディレクトリ/awstats.ホスト..html': そのようなファイルやディレクトリはありません」
と出てきます。


何分Linuxを触って間もないため、どこがどうなっているのかわかりません。
是非ともアドバイスをいただきたく存じます。

情報が足りませんでしたら、追って調べます。
記事編集 編集
Re: AWStatsにて集計結果が出ない このメッセージに返信する
日時: 2008/03/03 16:39
名前: aki
URL:
こんにちは。

スプリクトに間違いとかございませんか?
記事編集 編集
Re: AWStatsにて集計結果が出ない このメッセージに返信する
日時: 2008/03/03 21:16
名前: 吉田
URL:
こんばんわ。
作成したスクリプトを確認いたしましたが、リファレンスのものと相違ありませんでした。
記事編集 編集
Re: AWStatsにて集計結果が出ない このメッセージに返信する
日時: 2008/07/13 11:14
名前: na
URL:
遅いレスですが。。。
私も同じ状況でしたが解決しましたので投稿します。

私の場合は、コピペした際のミスでした。
日本の検索エンジン対応の設定で、カンマが1個抜けていました。
記事編集 編集
Re: AWStatsにて集計結果が出ない このメッセージに返信する
日時: 2008/07/13 17:12
名前: あび
URL:
原因はaccess_logに
>111.22.33.44 - - [10/Jan/2001:02:14:14 +0200] "GET / HTTP/1.1" 200 1234 "リファラ" "Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)"
の形であって欲しいのに
>リファラ - - [20/Jan/2008:10:30:39 +0900] "-" 200 16804 "-" "Snoopy v1.2.3"
となっているので解析が出来ないと言ってきているので
LogFormatの見直しが必要

カンマ抜けで出るエラーは
>String found where operator expected at ・・・
>syntax error at ・・・
記事編集 編集
Re: AWStatsにて集計結果が出ない このメッセージに返信する
日時: 2008/07/13 17:21
名前: amapola
URL:
/tmp/にawstatsという名前の付くファイルがあればそれをrm(削除)して見てください
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -