このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

Xen ドメインUOSインストールトラブル このメッセージに返信する
日時: 2007/12/14 16:59
名前: XENXEN
URL:
いつも本サイトを参考にさせていただいております。
Xen仮想化を、本サイトを参考に初めて設定してみました。
以下のとおり、手順を参考に進めてみたところ、
「Welcome to CentOS」の画面でOKとならず、ERROR出てしまいました。
接続先URLに問題がありそうなので、次画面で再入力するのですが、
やはり接続できません。リンク切れでもないようなのですが、
Google検索でも参考事例等がないため、
どなたかお分かりになる方はおられませんでしょうか。
よろしくお願いいたします。

# virt-install --nographics
What is the name of your virtual machine? CentOS5-1
How much RAM should be allocated (in megabytes)? 128
What would you like to use as the disk (path)? /var/lib/xen/images/CentOS5-1.img
How large would you like the disk (/var/lib/xen/images/CentOS5-1.img) to be (in gigabytes)?20
What is the install location? http://ftp.riken.jp/Linux/centos/5/os/i386/

Starting install...




省略




Welcome to CentOS

+-------------+ Error +--------------+
| |
| Unable to retrieve |
| http://ftp.riken.jp//Linux/centos/
5/os/i386/images/minstg2.img. |
| +----+ |
| |
| |
+------------------------------------+

*〜ftp.riken.jp//Linux/〜
        ↑
このスラッシュは修正しても入ってしまいます。
記事編集 編集
Re: Xen ドメインUOSインストールトラブル このメッセージに返信する
日時: 2007/12/14 17:04
名前: XENXEN
URL:
ヌケがありましたので補足いたします。
上記は、ゲストOSをCentOS5で導入、HDD容量は120Gで今回は20Gを使用(管理OSは30G)、
物理メモリは512Gを積んでおります。
トラブルは、ゲストOSインストール時に発生しました。

よろしくお願いいたします。
記事編集 編集
Re: Xen ドメインUOSインストールトラブル このメッセージに返信する
日時: 2007/12/14 17:53
名前: ZED
URL:
起動ディスクとインストール先が違うから起こっているんでしょう。

よくあるのが、
・CENTOS5.0用の起動ディスクを使用している。
・x86_64用の起動ディスクを使用している。

リンク以外の問題で言えば、この2点が濃厚です。
記事編集 編集
Re: Xen ドメインUOSインストールトラブル このメッセージに返信する
日時: 2007/12/17 01:44
名前: XENXEN
URL:
ZED様

ヘルプありがとうございます。

恐れ入りますが、起動ディスクとインストール先が違うとは
どのようなことでしょうか。

認識不足で大変申し訳ございません。
起動ディスクとは管理OSのことでしょうか。

管理OS上で本サイトを参考に進めていたので、
起動ディスクというものがよくわからない状況です。

お手数をおかけしますが、よろしくお願いいたします。



記事編集 編集
Re: Xen ドメインUOSインストールトラブル このメッセージに返信する
日時: 2007/12/17 12:08
名前: ZED
URL:
ごめんなさい、良く文面を読んでいませんでした。

例えば、ドメイン0がx86_64で構成されている場合。ごくまれにi386ですとエラーを起こす事があるとのことです。

また、インターネットにアクセスできていない可能性も考えられます。
たとえば、ドメイン0の端末から、
# ping -c 5 www.yahoo.co.jp
を実行してみてください。#はとって

PING www.yahoo.co.jp (203.216.235.154) 56(84) bytes of data.
64 bytes from www.yahoo.co.jp (203.216.235.154): icmp_seq=0 ttl=51 time=6.90 ms
64 bytes from www.yahoo.co.jp (203.216.235.154): icmp_seq=1 ttl=51 time=5.19 ms
64 bytes from www.yahoo.co.jp (203.216.235.154): icmp_seq=2 ttl=51 time=6.73 ms
64 bytes from www.yahoo.co.jp (203.216.235.154): icmp_seq=3 ttl=51 time=5.28 ms
64 bytes from www.yahoo.co.jp (203.216.235.154): icmp_seq=4 ttl=51 time=5.82 ms

--- www.yahoo.co.jp ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4001ms
rtt min/avg/max/mdev = 5.197/5.988/6.907/0.715 ms, pipe 2

のような結果が出ていれば、ネットへの疎通は確認できます。


次は、Manual TCP/IP Configuration で、
マニュアルでローカルIPを振っていますがDHCPがルーターについていたら、そちらを使っても構いません。

Configure TCP/IP で
| [*] Enable IPv4 support |
| (*) Dynamic IP configuration (DHCP) |
| ( ) Manual configuration
としてやってみてください。
記事編集 編集
Re: Xen ドメインUOSインストールトラブル このメッセージに返信する
日時: 2007/12/18 12:14
名前: XENXEN
URL:
ZEDさん

ヘルプありがとうございます。
ネットワーク疎通の確認から、その辺りを調べていたところ、
解決いたしました。

NICを2枚差しており、当初考えていたセグメント(192.168.2.0)側NICのIPでは認識しておらず、
もう一つのセグメント(192.168.1.0)側NICの方で認識していました。
認識している方のIPを振りなおしたところ、無事インストール完了まで行えました。

ヘルプありがとうございました。
非常に助かりました。
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -