このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

MySQL起動エラー このメッセージに返信する
日時: 2007/10/31 02:55
名前: 初心者
URL:

CentOS5にてMySQLのインストールをしているのですが、
・yum -y install mysql-server
・vi /etc/my.cnf
 default-character-set=ujis
 [mysql]
 default-character-set = ujis
 追加
・/etc/rc.d/init.d/mysqld start
 Timeout error occurred trying to start MySQL Daemon.

起動に失敗してしまいます。
何が悪いのか判らずに困っています。(上記のujisはUTF8でもやってみましたが、駄目でした)
どなたかご教授お願い致します。
記事編集 編集
Re: MySQL起動エラー このメッセージに返信する
日時: 2007/10/31 09:14
名前: 旅人
URL:
情報が少ないので
起動失敗時のログを提示しましょう。
/var/log/mysqld.logあたりにないですか?
記事編集 編集
Re: MySQL起動エラー このメッセージに返信する
日時: 2007/10/31 21:55
名前: 初心者
URL:

旅人さんのご指摘のログファイルです。
071031 21:51:57 mysqld started
071031 21:51:58 InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
071031 21:51:58 InnoDB: Starting log scan based on checkpoint at
InnoDB: log sequence number 0 36808.
InnoDB: Doing recovery: scanned up to log sequence number 0 43655
071031 21:51:58 InnoDB: Starting an apply batch of log records to the database...
InnoDB: Progress in percents: 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99
InnoDB: Apply batch completed
071031 21:51:58 InnoDB: Started; log sequence number 0 43655
071031 21:51:58 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist
071031 21:51:58 mysqld ended

これを見ると、「mysql.host」が存在しませんとエラー出してるように見えるのですが、この設定を
する場所ってどこなのでしょうか?宜しくお願いします。
記事編集 編集
Re: MySQL起動エラー このメッセージに返信する
日時: 2007/10/31 22:17
名前: 初心者
URL:
上記エラーでググってみたら、sh -x /etc/rc.d/init.d/mysqld startの結果も関係してそうなので、
取り敢えず張ってみます。(長いですが・・・・・)

と思ったら、文字数制限で駄目でした(泣)
どこか必要な箇所とかありますでしょうか?お願いします。

記事編集 編集
Re: MySQL起動エラー このメッセージに返信する
日時: 2007/10/31 22:37
名前: 初心者
URL:
http://kajuhome.com/cgi-bin/patio/patio.cgi?mode=view&no=564

上記URLの場所に書いてあるようにやったら、あっさり起動しました。
以上、報告まで。
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -