このスレッドは未解決です(解決したらこちらで解決済にしてください)
<<戻る

CentOS6,4でOpenVPN設定をしましたが、PINGがとおりません。 このメッセージに返信する
日時: 2014/04/16(Wed) 17:22
名前: きくぞう
URL:
現在、CentOS6.4をOpenVPNのサーバにし、クライアントのWindows7からVPN経由で
アクセスをさせようとしています。

以下のページを参考に設定をおこないました。
http://centossrv.com/openvpn.shtml

同じようなご質問をされている方もいるようなのですが、参考になる解決策が見当たりませんでした。

クライアントのWindows7からCentOS6.4のVPNサーバにはVPN接続は成功します。
しかし、クライアントからCentOS6.4へのVPNを使用した、pingが通じません。

■クライアントでの設定は以下のようになっています。
 Windowsファイアウォール無効にしています。

C:\>ipconfig/all

イーサネット アダプター ローカル エリア接続:

接続固有の DNS サフィックス . . . :
説明. . . . . . . . . . . . . . . : TAP-Windows Adapter V9
物理アドレス. . . . . . . . . . . : 00-FF-29-3D-FC-DA
DHCP 有効 . . . . . . . . . . . . : はい
自動構成有効. . . . . . . . . . . : はい
リンクローカル IPv6 アドレス. . . . : fe80::136:de3a:e9e3:a8fa%20(優先)
IPv4 アドレス . . . . . . . . . . : 10.8.0.6(優先)
サブネット マスク . . . . . . . . : 255.255.255.252
リース取得. . . . . . . . . . . . : 2014年4月16日 17:01:46
リースの有効期限. . . . . . . . . : 2015年4月16日 17:01:46
デフォルト ゲートウェイ . . . . . :
DHCP サーバー . . . . . . . . . . : 10.8.0.5
DHCPv6 IAID . . . . . . . . . . . : 318832425
DHCPv6 クライアント DUID. . . . . . . . : 00-01-00-01-1A-20-EC-F7-FC-61-98-9
-54-EC
DNS サーバー. . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over TCP/IP . . . . . . . : 有効


C:\>route print

IPv4 ルート テーブル
===========================================================================
アクティブ ルート:
ネットワーク宛先 ネットマスク ゲートウェイ インターフェイ
ス メトリック
0.0.0.0 0.0.0.0 172.19.XX.YY 172.19.XX.ZZZ 20
10.8.0.1 255.255.255.255 10.8.0.5 10.8.0.6 30
10.8.0.4 255.255.255.252 リンク上 10.8.0.6 286
10.8.0.6 255.255.255.255 リンク上 10.8.0.6 286
10.8.0.7 255.255.255.255 リンク上 10.8.0.6 286
10.250.64.0 255.255.255.0 10.8.0.5 10.8.0.6 30

■サーバの設定は以下のようになっています。

[root@ ~]# ifconfig
eth0 Link encap:Ethernet HWaddr 02:00:72:F7:00:01
inet addr:10.250.64.XXX Bcast:10.250.64.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:6079 errors:0 dropped:0 overruns:0 frame:0
TX packets:5707 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:699931 (683.5 KiB) TX bytes:669141 (653.4 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:101 errors:0 dropped:0 overruns:0 frame:0
TX packets:101 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:30238 (29.5 KiB) TX bytes:30238 (29.5 KiB)

tun0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:10.8.0.1 P-t-P:10.8.0.2 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:49 errors:0 dropped:0 overruns:0 frame:0
TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:3320 (3.2 KiB) TX bytes:588 (588.0 b)


[root@ ~]# netstat -rn
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
10.8.0.2 0.0.0.0 255.255.255.255 UH 0 0 0 tun0
10.8.0.0 10.250.64.135 255.255.255.0 UG 0 0 0 eth0
10.250.64.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
0.0.0.0 10.250.64.1 0.0.0.0 UG 0 0 0 eth0

[root@ ~]# iptables -nvL
Chain INPUT (policy ACCEPT 39 packets, 2926 bytes)
pkts bytes target prot opt in out source destination
0 0 ACCEPT all -- tun+ * 0.0.0.0/0 0.0.0.0/0

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination
0 0 ACCEPT all -- tun+ * 0.0.0.0/0 10.250.64.XXX
0 0 ACCEPT all -- * tun+ 0.0.0.0/0 0.0.0.0/0

Chain OUTPUT (policy ACCEPT 33 packets, 3658 bytes)
pkts bytes target prot opt in out source destination
0 0 ACCEPT all -- * tun+ 0.0.0.0/0 0.0.0.0/0

iptablesの設定は全てクリアしても同じでした。


上記の設定で、クライアントのWindows7から以下のコマンドを実行してもすべて成功しません。
ルーティングかファイアウォールの設定に問題があるのかと思いますが、何が問題なのか全然わかりませんn
ので、何か情報を頂ければ幸いです。


C:\>ping 10.8.0.1

10.8.0.1 に ping を送信しています 32 バイトのデータ:
要求がタイムアウトしました。
要求がタイムアウトしました。
要求がタイムアウトしました。
要求がタイムアウトしました。

10.8.0.1 の ping 統計:
パケット数: 送信 = 4、受信 = 0、損失 = 4 (100% の損失)、

C:\>ping 10.250.64.XXX

10.250.64.XXX に ping を送信しています 32 バイトのデータ:
要求がタイムアウトしました。
要求がタイムアウトしました。
要求がタイムアウトしました。
要求がタイムアウトしました。

10.250.64.XXX の ping 統計:
パケット数: 送信 = 4、受信 = 0、損失 = 4 (100% の損失)、


他に提示すべき情報がありましたら、ご指摘ください。

以上、宜しくお願いいたします。
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -