このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

CentoOS6にてpingがルータに到達しません。 このメッセージに返信する
日時: 2011/08/01 12:24
名前: quest
URL: http://ameblo.jp/eroweb/
minumum+GUIで無事インストール、初期設定しました。
SSHのポートを変えて、windowsからPederosaで操作も確認しました。
ところがyumもwgetも出来ません。

あれ?と思いまして、
# ping google.com
と打つとしばらく無反応。その後
ping: unknown host google.com
と出ます。あれDNS系かな?と思いましたが、もしやと思い

# ping 192.168.1.1 //ルータ
と打つと
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
で止まります。
しょうがないので強制キャンセル
--- 192.168.1.1 ping statistics ---
24 packets transmitted, 0 received, 100% packet loss, time 23570ms
で到達していないようです。

設定として、NIC2本差ですが、今は一本しか用意していませんでした。
そのeth0の設定が

DEVICE=eth0
NM_CONTROLLED=yes
ONBOOT=yes
TYPE=Ethernet
BOOTPROTO=none
IPADDR=192.168.1.254
PREFIX=24
GATEWAY=192.168.1.1
DNS1=192.168.1.1
IPV4_FAILURE_FATAL=yes
NAME="System eth0"
UUID=******-****-****-****...
HWADDR=**:**:**:...
IPV6INIT=no
PEERDNS=no
USERCTL=no
NETWORK=192.168.1.0

一回ONBOOT=noにして、eth1の方をyes、BOOTPROTOをdhcpにして
# service network restart
本体GUIのターミナルからですが、なぜか無事ping通りました。
そして無事yum updateが終わり、翌朝設定の続きでもと思いましたらまた最初の症状・・

再度eth1を殺してeth0を復活。networkリブート。
すると無事繋がりました。

そして外からまたSSHで接続し、動作を見るとまた繋がらない。。

・SSHは安定して繋がる
・pingもdigもルータまでつながれば外部に繋がるが、すぐに繋がらなくなる。
・自宅回線はフレッツネクスト。ルータのIPv6は殺しちゃダメらしい。
・サーバへは 光(固定IP)-----ルータ(192.168.1.1)-----HUB-----サーバ(192.168.1.254)
・/etc/sysconfig/network-scripts/ifcfg-eth0は上記
・cat /etc/resolv.conf
search *********
nameserver 192.168.1.1
・cat /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=***.***.***
GATEWAY=192.168.1.1

ちなみに昨日頭に来て再インストールしようとしましたが、なぜか「そんなRAMはねぇ」という感じのメッセージが出て、
なぜか再インストールも出来ませんでした。

光電話とかひかりTVなども使っているので、(調べるのが面倒だったので)ブリッジモード使うのも気が引けまして。
何か同様の症状の方、
もしくは疑わしい箇所の確認など、ございませんでしょうか?
記事編集 編集

Page: | 1 | 2 |

Re: CentoOS6にてpingがルータに到達しません。 このメッセージに返信する
日時: 2011/08/01 15:18
名前: quest
URL: http://ameblo.jp/eroweb/
> stranger様
ありがとうございます。
結果から言うと改善出来ませんでした。

まずifconfigのeth0とeth1:
eth0 Link encap:Ethernet HWaddr **:**:**:...
inet addr:192.168.1.254 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:25 errors:0 dropped:0 overruns:0 frame:0
TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2269 (2.2 KiB) TX bytes:6477 (6.3 KiB)
Interrupt:16

eth1 Link encap:Ethernet HWaddr **:**:**:**...
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:17

変更したifcfg-eth0:
DEVICE=eth0
NM_CONTROLLED=no
ONBOOT=yes
TYPE=Ethernet
BOOTPROTO=static
IPADDR=192.168.1.254
PREFIX=24
GATEWAY=192.168.1.1
DNS1=192.168.1.1
NAME="System eth0"
UUID=******-****-...
HWADDR=**:**:**:....
NETWORK=192.168.1.0
PEERDNS=no
USERCTL=no

あとご指摘のフォルダは初めて触りました。。
/etc/modprobe.d/の中身ですが
# ll /etc/modprobe.d/

-rw-r--r--. 1 root root 52 7月 30 08:36 2011 anaconda.conf
-rw-r--r--. 1 root root 16 5月 20 18:13 2009 blacklist-visor.conf
-rw-r--r--. 1 root root 884 11月 12 18:10 2010 blacklist.conf
-rw-r--r-- 1 root root 43 8月 1 14:37 2011 dev-off.conf
-rw-r--r--. 1 root root 23 7月 30 09:34 2011 disable-ipv6.conf
-rw-r--r--. 1 root root 382 11月 12 15:13 2010 dist-alsa.conf
-rw-r--r--. 1 root root 473 11月 12 15:13 2010 dist-oss.conf
-rw-r--r--. 1 root root 5596 11月 12 15:13 2010 dist.conf
-rw-r--r--. 1 root root 30 10月 10 12:38 2009 openfwwf.conf

なんか気になるファイルがありますが、中身は
# cat disable-ipv6.conf
install ipv6 /bin/true

となっております。
記事編集 編集
Re: CentoOS6にてpingがルータに到達しません。 このメッセージに返信する
日時: 2011/08/01 15:29
名前: quest
URL: http://ameblo.jp/eroweb/
あとちなみにdist.confの中身ですが、
〜略〜
install net-pf-19 /bin/true
install net-pf-3 /bin/true
install net-pf-6 /bin/true
〜略〜
となってました。関係無かったらすみません。
記事編集 編集
Re: CentoOS6にてpingがルータに到達しません。 このメッセージに返信する
日時: 2011/08/01 16:13
名前: stranger
URL: http://ja.528p.com/
disable-ipv6.conf
install ipv6 /bin/true
のように設定されているとこちらでも無効になるようです
ifconfig -a
でipv6のaddressが出ていなければ良いです

私のテストマシンは networkは自動設定で、BASEのみをインストールし
起動後にnetworkの設定を行い、インターネットに接続
手動で必要なパッケージをインストールしています

networkが起動していて、つながらない理由が良くわかりません

ルータの方で192.168.1.254はDHCPから除外されていますよね
記事編集 編集
Re: CentoOS6にてpingがルータに到達しません。 このメッセージに返信する
日時: 2011/08/01 16:33
名前: quest
URL: http://ameblo.jp/eroweb/
> stranger様
ありがとうございます。
IPv6はインストーラの時点で殺していました。
デフォでファイアウォール入れるとip6tablesみたいなのも入るみたいですね。
正直よく分からないです。IPv6。

> 私のテストマシンは networkは自動設定で、BASEのみをインストールし
> 起動後にnetworkの設定を行い、インターネットに接続
> 手動で必要なパッケージをインストールしています

> networkが起動していて、つながらない理由が良くわかりません

> ルータの方で192.168.1.254はDHCPから除外されていますよね

DHCPからはもちろん外してます。
リポジトリも何せwgetすら出来ない状態ですので・・初期のままなんですが。

まずはありがとうございました。
記事編集 編集
Re: CentoOS6にてpingがルータに到達しません。 このメッセージに返信する
日時: 2011/08/03 00:23
名前: quest
URL: http://ameblo.jp/eroweb/
再インストールしました。
何故か素直に再インストールしなかったので、SLを一回入れてから再度Cent6入れたら出来ました。
それも謎ですが。。

strangerさんを習って、初期ではウィザード中のネットワーク設定時にIPv4、IPv6共に殺して起動もしない。
BIOSでNIC1枚殺す。
そのあたりを徹底し、一度立ち上がった後でターミナルを起動。
/etc/sysconfig/network
ifcfg-eth0
resolv.conf
modprobe.d内の上記ファイル
あたりを丁寧に設定。
再起動したら無事に繋がりました。

ip6tablesがあったり
newaliases時にIPv6設定してないと文句言われたり。。
時代ですかね。
でも分からないんですよね。。
記事編集 編集
Re: CentoOS6にてpingがルータに到達しません。 このメッセージに返信する
日時: 2011/08/03 01:13
名前: quest
URL: http://ameblo.jp/eroweb/
終了させましたが、症状が特定できましたのでご報告します。
ルータのDMZをサーバに向けたらいきなりping不能になる。

というのが分かりました。
原因は不明です。。。Cent5.6の時にはもちろんこんな症状はありませんでした。
記事編集 編集
Re: CentoOS6にてpingがルータに到達しません。 このメッセージに返信する
日時: 2011/08/03 01:35
名前: quest
URL: http://ameblo.jp/eroweb/
解決しました。
ルータはNTTのPR-S300HIを使っています。

原因:静的NAT設定でワンタッチ設定をひとつでもチェックしていると起こります。
簡易DMZで全向けしてサーバでファイアウォール設定しようとしてもダメです。

解決策:その下の1〜64まで設定できる箇所、そこで設定してください。80番もです。
また優先順位を0にすると向かないようです。

結論:ルータのバグ?
記事編集 編集
Re: CentoOS6にてpingがルータに到達しません。 このメッセージに返信する
日時: 2011/08/03 05:10
名前: アンテナショップ
URL:
参考
http://www.akakagemaru.info/port/PR-S300HI.html
記事編集 編集
Re: CentoOS6にてpingがルータに到達しません。 このメッセージに返信する
日時: 2011/08/03 08:52
名前: quest
URL: http://ameblo.jp/eroweb/
ありがとうございます、これです。
問題はこれのワンタッチ設定でサーバに向けられない事ですね。
記事編集 編集

Page: | 1 | 2 |

件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -