このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

PHPの最新版をソースからインストールできないか このメッセージに返信する
日時: 2011/04/24 07:38
名前: つばさ
URL:
お世話になっております
PHP53になって なくなったものがあるようですね
phpadminなどには影響したりするようです
そこで ページを検索してみるのですが良い方法がみつかりません
本家から 最新版のパッケージから makeして インストールする方法をご存知の方いらっしゃいましたら
教授してもらえないでしょうか
rpm -q centos-release
centos-release-5-6.el5.centos.1
CentOS5.6にアップデートはおります

記事編集 編集
Re: PHPの最新版をソースからインストールできないか このメッセージに返信する
日時: 2011/04/25 08:12
名前: ZED
URL:
strangerさんのサイトで公開してますよ?
http://ja.528p.com/linux/centos/SL004-configsh.html

ちなみに、5.5の時代から5.3系をyumで管理させていますので、影響ないのですが、どういった影響が出ていますか?

いま、うちの全サーバーに入っている物
PHP 5.3.6 (cli) (built: Apr 15 2011 18:11:25)
Server version: 5.5.11 MySQL Community Server (GPL) by Remi
記事編集 編集
Re: PHPの最新版をソースからインストールできないか このメッセージに返信する
日時: 2011/04/25 12:52
名前: stranger
URL: http://ja.528p.com/
サイトを紹介してもらってありがたいのですが
どのようにconfigureを設定するか どのようにphp.iniを設定するか
個人の環境によるので、失敗しても自己責任でお願いします
phpでさしあたって必要のないものを動的リンクにしようと思い
configureとphp.iniを修正中です、近々書き換えるつもりです

php53のrpmパッケージでなにが無くなったのか
それが作成者の意図によるものなのか
phpソースそのものでサポートされなくなったのか
十分理解して進めないとソースから入れる意味がうすれます

specファイルのconfigureの部分で修正できるなら
src.rpmをダウンロードしてきて
specファイルを書き換え、自分のrpmパッケージをつくることを推めます


記事編集 編集
Re: PHPの最新版をソースからインストールできないか このメッセージに返信する
日時: 2011/04/25 20:01
名前: つばさ
URL:
>サイトを紹介してもらってありがたいのですが
>どのようにconfigureを設定するか どのようにphp.iniを設定するか
>個人の環境によるので、失敗しても自己責任でお願いします
>phpでさしあたって必要のないものを動的リンクにしようと思い
>configureとphp.iniを修正中です、近々書き換えるつもりです
>
>php53のrpmパッケージでなにが無くなったのか
>それが作成者の意図によるものなのか
>phpソースそのものでサポートされなくなったのか
>十分理解して進めないとソースから入れる意味がうすれます
>
>specファイルのconfigureの部分で修正できるなら
>src.rpmをダウンロードしてきて
>specファイルを書き換え、自分のrpmパッケージをつくることを推めます
>
>
>
そうですね
一旦閉じさせて頂きますね
再度 整理して 質問させて頂きます
レス 有難うございました
また よろしくお願いします
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -