このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

awstats htmlリンク一部表示エラー このメッセージに返信する
日時: 2011/03/30 12:10
名前: kuni
URL:
お世話様です。

このサイトのApacheアクセスログ解析(AWStats)を参考にトライしてるのですがどうしても解決出来ない問題があり、教えて頂きたく投稿してます。
http://Webサーバー名/awstats/awstats.plここまでは問題なく表示されるのですが、
http://Webサーバー名/awstatsreport/でアクセスすると一応は表示されるのですが一部リンクがサーバー内データと合わずエラーとなってしまいます。
[root@cent ~]# ll /var/www/awstatsreport/
合計 232
-rw-r--r-- 1 root root 6438 3月 30 10:46 awstats.○△×.com.201103.alldomains.html
-rw-r--r-- 1 root root 5770 3月 30 10:46 awstats.○△×.com.201103.allhosts.html
-rw-r--r-- 1 root root 6287 3月 30 10:46 awstats.○△×.com.201103.allrobots.html
-rw-r--r-- 1 root root 6598 3月 30 10:46 awstats.○△×.com.201103.browserdetail.html
-rw-r--r-- 1 root root 5760 3月 30 10:46 awstats.○△×.com.201103.errors404.html
-rw-r--r-- 1 root root 5176 3月 30 10:46 awstats.○△×.com.201103.keyphrases.html


-rw-r--r-- 1 root root 74204 3月 30 10:46 index.html
一部省略してますがこのような内容です。
ブラウザー(IE&Firefox)でのリンク先が全てドメイン前のawstats.が無く○△×.com.201103.keyphrases.htmlのようになっています。

なにぶん初心者につき上手に説明できたか不安ですが・・・
宜しくご指導お願いいたします。
記事編集 編集
Re: awstats htmlリンク一部表示エラー このメッセージに返信する
日時: 2011/03/30 17:44
名前: mugi
URL:
私も同様のエラーが出たので、便乗させてもらいます。

awstats-6.95-1.el5.rfを、awstats-7.0-1.el5.rfにアップデートすると、
index.htmlのリンクから awstats. が無くなってしまいます。

<a href="(ドメイン名).201103.osdetail.html" target="awstatsbis">バージョン</a>
(上のリンクにawstatsが付いてません。)

どなたか、この件で、ご教示願います。
記事編集 編集
Re: awstats htmlリンク一部表示エラー このメッセージに返信する
日時: 2011/03/31 11:02
名前: JK大好き
URL:
awstats.ドメイン名.201103.******.html
これのawstats.を無くした ドメイン名.201103.******.htmlで出力する事は簡単なんですが
後の事を考えると却下で、index.htmlを修正できる方法が一番良いのですが、
試行錯誤しましたが私には分かりませんでした。


http://www.directadmin.com/forum/showthread.php?t=38820
こちらでも取り沙汰されていますが、バグのようで6.95に戻して使っているようです。


# wget http://packages.sw.be/awstats/awstats-6.95-1.el5.rf.noarch.rpm
# rpm -Uhv --oldpackage awstats-6.95-1.el5.rf.noarch.rpm
# rm -f awstats-6.95-1.el5.rf.noarch.rpm

これで簡単に戻せます。
戻した場合はAWStatsが自動でバージョンアップしないようにしないと、また同じ事になります。


解決策ではなくすみません。
記事編集 編集
Re: awstats htmlリンク一部表示エラー このメッセージに返信する
日時: 2011/03/31 11:48
名前: kuni
URL:
>awstats.ドメイン名.201103.******.html
>これのawstats.を無くした ドメイン名.201103.******.htmlで出力する事は簡単なんですが
>後の事を考えると却下で、index.htmlを修正できる方法が一番良いのですが、
>試行錯誤しましたが私には分かりませんでした。
>
>
>http://www.directadmin.com/forum/showthread.php?t=38820
>こちらでも取り沙汰されていますが、バグのようで6.95に戻して使っているようです。
>
>
># wget http://packages.sw.be/awstats/awstats-6.95-1.el5.rf.noarch.rpm
># rpm -Uhv --oldpackage awstats-6.95-1.el5.rf.noarch.rpm
># rm -f awstats-6.95-1.el5.rf.noarch.rpm
>
>これで簡単に戻せます。
>戻した場合はAWStatsが自動でバージョンアップしないようにしないと、また同じ事になります。
>
>
>解決策ではなくすみません。

JK大好きさん、
アドバイスありがとうございます。
バグではしかたないですね。
ご指摘のように戻すことにします。

これで解決済みとさせていただきます。
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -