このスレッドは未解決です(解決したらこちらで解決済にしてください)
<<戻る

yum update でエラー このメッセージに返信する
日時: 2011/03/01 11:47
名前: hiyoko
URL:
パッケージのアップデートでエラーが出ており、アップデート出来ない状態となっていました。
問題のパッケージ以外は手動でアップデートを行いましたが、下記パッケージが未だアップデート出来ない状態です。

geos.i386 0:3.2.2-1.el5.rf
geos-devel.i386 0:3.2.2-1.el5.rf

このままだと自動でアップデート出来ないので、yumのアップデートリストから除外しようかと思いましたが、根本的な解決にならいと思いますのでどなたかご教授お願いいたします。

# yum update
Loaded plugins: downloadonly, fastestmirror, priorities, versionlock
Loading mirror speeds from cached hostfile
* addons: ftp.nara.wide.ad.jp
* base: ftp.nara.wide.ad.jp
* extras: ftp.nara.wide.ad.jp
* rpmforge: fr2.rpmfind.net
* updates: ftp.nara.wide.ad.jp
Excluding Packages in global exclude list
Finished
80 packages excluded due to repository priority protections
Reading version lock configuration
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package geos.i386 0:3.2.2-1.el5.rf set to be updated
--> Processing Dependency: libgeos-3.1.0.so for package: gdal
---> Package geos-devel.i386 0:3.2.2-1.el5.rf set to be updated
--> Finished Dependency Resolution
gdal-1.4.4-2.el5.rf.i386 from installed has depsolving problems
--> Missing Dependency: libgeos-3.1.0.so is needed by package gdal-1.4.4-2.el5.rf.i386 (installed)
Error: Missing Dependency: libgeos-3.1.0.so is needed by package gdal-1.4.4-2.el5.rf.i386 (installed)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
記事編集 編集
Re: yum update でエラー このメッセージに返信する
日時: 2011/03/01 13:56
名前: stranger
URL: http://ja.528p.com/
gdalの方が重要でしょうから
geosをexcludeしたほうが良いのでは?

geos-devel-3.2.2に含まれているライブラリは
libgeos-3.2.2.soになっているので
geosを強制的にアップデートして
gdal-1.4.4-2.rf.src.rpm から再構築しないと
Processing Dependency: libgeos-3.1.0.so for package: gdal
は解決しないと思う

libgeos-3.1.0.soでないとgdalが動かないものかどうかは
私にはわかりませんので悪しからず

記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -