このスレッドは未解決です(解決したらこちらで解決済にしてください)
<<戻る

snortのインストールがうまくいかない このメッセージに返信する
日時: 2010/10/30 20:27
名前: gotengo
URL:
http://centossrv.com/snort-base.shtml
こちらの方で
[root@fedora ~]# wget http://dl.snort.org/snort-current/snort-2.8.4.1.tar.gz ← snortダウンロード
を実行しようとしたところ、最新版のバージョンにURLを変えてもダウンロードされなかったため、FTPでsnort-2.9.0.tar.gzを移動させてから/rootに置いて
rpmbuildで「ビルドの依存性の失敗」ででてきたソフトをyumでダウンロードしてもう一度rpmbuildを実行したところ、以下のようなエラー文が出て終了してしまいました。


checking for libpcre version 6.0 or greater... yes
./configure: line 13760: dnet-config: command not found
./configure: line 13766: dnet-config: command not found
checking dnet.h usability... no
checking dnet.h presence... no
checking for dnet.h... no

ERROR! dnet header not found, go get it from
http://code.google.com/p/libdnet/ or use the --with-dnet-*
options, if you have it installed in an unusual place
+ '[' plain = mysql ']'
+ '[' plain = postgresql ']'
+ '[' plain = unixODBC ']'
+ '[' plain = oracle ']'
+ /usr/bin/make
make: *** No targets specified and no makefile found. Stop.
エラー: /var/tmp/rpm-tmp.11616 の不正な終了ステータス (%build)


RPM ビルドエラー:
/var/tmp/rpm-tmp.11616 の不正な終了ステータス (%build)


dnetというのがないのだと思いましたが、dnetが何なのか、ググってもわかりませんでした。
足りないものなら前述のrpmbuildのエラーで出る筈ですし、どうすればいいのでしょうか?
記事編集 編集

Page: | 1 | 2 |

Re: snortのインストールがうまくいかない このメッセージに返信する
日時: 2010/11/03 17:11
名前: stranger
URL: http://ja.528p.com/
centosのlibpcapのsoヴァージョンはlibpcap.so.0.9.4になっています
http://www.tcpdump.org/
からlibpcap-1.1.1.tar.gzをダウンロードして
自前でmakeしてインストールするしかないかも
その場合、libpcap.so.1.1.1になります
libpcap-1.0.0.tar.gzなら
libpcap.so.1.0.0が作られると思う
インストールの方法 ライブラリの認識の方法は 略
どなたかお助けを
記事編集 編集
сумки Луи Витон このメッセージに返信する
日時: 2013/08/02(Fri) 13:52
名前: 065155
URL: http://louisvuitton.web-box.ru/
HITACHIのW32-PDH3000右スピーカーが故障してるのか音がザーとなります。買い取り可能でしょうか? сумки Луи Витон http://louisvuitton.web-box.ru/
記事編集 編集

Page: | 1 | 2 |

件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -