このスレッドは未解決です(解決したらこちらで解決済にしてください)
<<戻る

Logwatchのamavisについて このメッセージに返信する
日時: 2010/05/08 11:05
名前: 私です
URL:

お世話になっております。

当サイトを参考にさせていただき、CentOS5.4でサーバを構築していますが、
最近、Logwatchのamavis Beginに以下のような出力がでてくるようになりました。

↓↓↓ ここから ↓↓↓
**Unmatched Entries**
(!)Decoding of p003 (Zip archive data, at least v2.0 to extract) failed, leaving it unpacked: Compress::Raw::Zlib defines neither package nor VERSION--version check failed at (eval 78) line 467.: 6 Time(s)
(!)Decoding of p002 (Zip archive data, at least v2.0 to extract) failed, leaving it unpacked: Compress::Raw::Zlib defines neither package nor VERSION--version check failed at (eval 78) line 467.: 4 Time(s)
(!)Decoding of p004 (Zip archive data, at least v2.0 to extract) failed, leaving it unpacked: Compress::Raw::Zlib defines neither package nor VERSION--version check failed at (eval 78) line 467.: 2 Time(s)
↑↑↑ ここまで ↑↑↑

バージョンチェックが失敗しているようにも見えますが、
この状態で問題はないのでしょうか?

お手数ですが、ご教示いただきたく、よろしくお願いいたします。



記事編集 編集
Re: Logwatchのamavisについて このメッセージに返信する
日時: 2011/02/16 14:35
名前: foo
URL:

このままだとZipファイルのチェックはほぼ全部失敗する(チェックされずにスルー)ので影響はあるのではないでしょうか?(こちらは現在CentOS5.5ですが同じ現象になりました。)

原因はamavisd-newの2.6.4からCompress::Raw::Zlibのバージョンチェックをするように
なったようですが、
Compress::Raw::Zlibをuseで読みこんでいないため、バージョンチェック自体に失敗
(文法エラー的な)しているようです。

手っ取り早い対処としては/usr/sbin/amavisの

Compress::Raw::Zlib->VERSION(2.017); # required minimal version, or die
のある行の手前で
use Compress::Raw::Zlib;

とするか

「Compress::Zlib」を検索してfetch_modulesしている行の後ろ(223行目?)に
Compress::Raw::Zlibを追加するか
でしょうか。

こうすると、zipのチェックを行ってくれました。(私は後者をやりました)

結局amavisd-newのバグ?という印象だったので直接手を入れましたが、他に
もっとよい対処法があればご教授ください。

# すでに解決済みなら、ご容赦ください

amavisd-newがはやく直れば問題解決なんですが...

>
>お世話になっております。
>
>当サイトを参考にさせていただき、CentOS5.4でサーバを構築していますが、
>最近、Logwatchのamavis Beginに以下のような出力がでてくるようになりました。
>
>↓↓↓ ここから ↓↓↓
> **Unmatched Entries**
> (!)Decoding of p003 (Zip archive data, at least v2.0 to extract) failed, leaving it unpacked: Compress::Raw::Zlib defines neither package nor VERSION--version check failed at (eval 78) line 467.: 6 Time(s)
> (!)Decoding of p002 (Zip archive data, at least v2.0 to extract) failed, leaving it unpacked: Compress::Raw::Zlib defines neither package nor VERSION--version check failed at (eval 78) line 467.: 4 Time(s)
> (!)Decoding of p004 (Zip archive data, at least v2.0 to extract) failed, leaving it unpacked: Compress::Raw::Zlib defines neither package nor VERSION--version check failed at (eval 78) line 467.: 2 Time(s)
>↑↑↑ ここまで ↑↑↑
>
>バージョンチェックが失敗しているようにも見えますが、
>この状態で問題はないのでしょうか?
>
>お手数ですが、ご教示いただきたく、よろしくお願いいたします。
>
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -