このスレッドは未解決です(解決したらこちらで解決済にしてください)
<<戻る

ページが表示されない このメッセージに返信する
日時: 2009/04/23 11:30
名前: うぃ
URL:
ここのサイトどおりに構築したのですが、
ページが表示されません。

メインページは表示されるのですが、
ユーザーのページが表示されません。

http://xxxx.jp/
http://xxxx.jp/~xxxx/ ←ココ(全てのユーザーで該当)
ごくまれに表示されることがあります。

以前は、表示されていたのですが、
サーバーの移設をしてから表示されなくなってしまいました。
全く原因がわかりません。
エラーも出ていないです。(真っ白な状態)

どなたかご教授お願いできないでしょうか
宜しくお願いいたします。;;
記事編集 編集

Page: | 1 | 2 | 3 |

Re: ページが表示されない このメッセージに返信する
日時: 2009/04/24 18:08
名前: stranger
URL: http://ja.528p.com/
index.htmlのユーザ・グループ・パーミッションは?
apache(httpdのユーザ)が読み込むことが出来る設定ですか?

レスポンスコード404は リクエストURI に一致するファイルを見つけられない
記事編集 編集
Re: ページが表示されない このメッセージに返信する
日時: 2009/04/25 09:08
名前: 中学生管理者
URL:
>サーバーの移設をしてから表示されなくなってしまいました。

>エラーも出ていないです。(真っ白な状態)

>ErrorDocument 403 /403error.html
>ErrorDocument 404 /404error.html
>ErrorDocument 500 /500error.html

404エラーが出ること自体もおかしいのですが、
エラーで真っ白なのは、エラーページを作ったのをお忘れだからでは?
エラーページの存在、パーミッション、エンコードなどチェック。
記事編集 編集
Re: ページが表示されない このメッセージに返信する
日時: 2009/04/25 11:50
名前: tsuge
URL:
mod_userdirが正常に動作してるのかな ?
記事編集 編集
Re: ページが表示されない このメッセージに返信する
日時: 2009/04/25 15:45
名前: stranger
URL: http://ja.528p.com/
>mod_userdirが正常に動作してるのかな ?

index.html以外は表示できると言うことなので
index.htmlを一時的に、簡単なtestを表示するものに変えて試すとか
それで表示されるなら 最初のindex.htmlの作りの問題でしょ
それでも表示されないなら、httpd.confの問題?

そもそも、phpなどで動的に作成されるhtmlファイルでない限り
apacheで表示しなくてもfirefoxで表示できる(javaスクリプトもOK)
のだからクライアントマシンで試す事もできます
記事編集 編集
Re: ページが表示されない このメッセージに返信する
日時: 2009/04/25 17:09
名前: うぃ
URL:

解決しました。
UIDとGIDの不整合だったようです。

試しに、UIDとGIDを一致させたら
ページが表示されました。

strangerさん、中学生管理者さん、tsugeさん
ありがとうございました。


■実施事項
id xxxx
groupmod -g GID xxxx
usermod -g xxxx xxxx
chown -R xxxx:xxxx /home/xxxx
記事編集 編集
Re: ページが表示されない このメッセージに返信する
日時: 2009/04/26 15:24
名前: stranger
URL: http://ja.528p.com/
蛇足

両方書いてあってもエラーにならないと思うけど、意味ない
<IfModule prefork.c>
StartServers 8
MinSpareServers 5
MaxSpareServers 20
ServerLimit 256
MaxClients 256
MaxRequestsPerChild 4000
</IfModule>

<IfModule worker.c>
StartServers 2
MaxClients 150
MinSpareThreads 25
MaxSpareThreads 75

ThreadsPerChild 25
MaxRequestsPerChild 0
</IfModule>

httpd -M
を実行して組み込まれている方(デフォルトはprefork)を有効にする

最後のLocationが閉じていないけど書き忘れ?
<Location />
</Location>
記事編集 編集
Re: ページが表示されない このメッセージに返信する
日時: 2009/04/27 10:54
名前: うぃ
URL:
>蛇足
>
><IfModule worker.c>
>StartServers 2
>MaxClients 150
>MinSpareThreads 25
>MaxSpareThreads 75
>
>ThreadsPerChild 25
>MaxRequestsPerChild 0
></IfModule>
>

コメントアウトしました。

>httpd -M
>を実行して組み込まれている方(デフォルトはprefork)を有効にする
>
>最後のLocationが閉じていないけど書き忘れ?
><Location />
></Location>

はい、書き忘れでした;
ありがとうございました。
記事編集 編集

Page: | 1 | 2 | 3 |

件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -