このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

samba smb.conf について このメッセージに返信する
日時: 2009/02/04 20:36
名前: dan
URL:

samba初心者の鈴木です。
sambaの設定がうまくいかないので、

# rpm -aq|grep samba
samba-3.0.28-1.el5_2.1
samba-common-3.0.28-1.el5_2.1
samba-client-3.0.28-1.el5_2.1

これらの依存性を解決し全て削除して、

yum -y install samba しました。

再度、初めから設定しましたがうまくいきませんでした。

smb.conf が削除前と変わっていないことに気付き、

rm -rf /etc/samba/smb.conf
rm -rf /etc/samba

で削除し、再度

yum -y install samba で

インストールしましたが、

/etc/samba/smb.conf これが無くて困ってます。

どのようにすれば/etc/samba/smb.confが インストールできるのでしょうか?


記事編集 編集
Re: samba smb.conf について このメッセージに返信する
日時: 2009/02/04 21:00
名前: aki
URL:
rpm -q samba-common は?
記事編集 編集
Re: samba smb.conf について このメッセージに返信する
日時: 2009/02/04 22:45
名前: dan
URL:
>rpm -q samba-common は?
>
rpm -q samba-common は

samba-common-3.0.28-1.el5_2.1
となります。

samba-commonのアンインストールが不完全なようなので、

rpm -e samba-common-3.0.28-1.el5_2.1
とすると、

エラー: 依存性の欠如:
libsmbclient.so.0 は (インストール済み)kdebase-3.5.4-18.el5.centos.i386 に必要とされています
samba-common = 0:3.0.28-1.el5_2.1 は (インストール済み)samba-client-3.0.28-1.el5_2.1.i386 に必要とされています
samba-common = 0:3.0.28-1.el5_2.1 は (インストール済み)samba-3.0.28-1.el5_2.1.i386 に必要とされています

なので、

rpm -e kdebase-3.5.4-18.el5.centos.i386

とすると、
エラー: 依存性の欠如:
libkasbar.so.1 は (インストール済み)kdebase-devel-3.5.4-18.el5.centos.i386 に必要とされています
libkateinterfaces.so.0 は (インストール済み)kdeaddons-3.5.4-1.fc6.i386 に必要とされています
libkateinterfaces.so.0 は (インストール済み)kdebase-devel-3.5.4-18.el5.centos.i386 に必要とされています
libkateutils.so.0 は (インストール済み)kdebase-devel-3.5.4-18.el5.centos.i386 に必要とされています
libkdecorations.so.1 は (インストール済み)kdeartwork-3.5.4-1.fc6.i386 に必要とされています
libkdecorations.so.1 は (インストール済み)kdebase-devel-3.5.4-18.el5.centos.i386 に必要とされています
libkfontinst.so.0 は (インストール済み)kdebase-devel-3.5.4-18.el5.centos.i386 に必要とされています
libkhotkeys_shared.so.1 は (インストール済み)kdebase-devel-3.5.4-18.el5.centos.i386 に必要とされています
libkickermain.so.1 は (インストール済み)kdebase-devel-3.5.4-18.el5.centos.i386 に必要とされています
libkonq.so.4 は (インストール済み)kdeaddons-3.5.4-1.fc6.i386 に必要とされています
libkonq.so.4 は (インストール済み)kdebase-devel-3.5.4-18.el5.centos.i386 に必要とされています
libkonqsidebarplugin.so.1 は (インストール済み)kdeaddons-3.5.4-1.fc6.i386 に必要とされています
libkonqsidebarplugin.so.1 は (インストール済み)kdebase-devel-3.5.4-18.el5.centos.i386 に必要とされています
libksgrd.so.1 は (インストール済み)kdebase-devel-3.5.4-18.el5.centos.i386 に必要とされています
libksplashthemes.so.0 は (インストール済み)kdebase-devel-3.5.4-18.el5.centos.i386 に必要とされています
libtaskbar.so.1 は (インストール済み)kdebase-devel-3.5.4-18.el5.centos.i386 に必要とされています
libtaskmanager.so.1 は (インストール済み)kdebase-devel-3.5.4-18.el5.centos.i386 に必要とされています
kdebase >= 6:3.5.4 は (インストール済み)kdegraphics-3.5.4-6.el5.i386 に必要とされています
kdebase >= 6:3.5.4 は (インストール済み)kdemultimedia-3.5.4-2.fc6.i386 に必要とされています
kdebase >= 6:3.5.4 は (インストール済み)kdeutils-3.5.4-5.fc6.i386 に必要とされています
kdebase >= 6:3.5.4 は (インストール済み)kdenetwork-3.5.4-4.fc6.i386 に必要とされています
kdebase >= 6:3.5.4 は (インストール済み)kdepim-3.5.4-4.fc6.i386 に必要とされています
kdebase >= 6:3.5.4 は (インストール済み)kdebindings-3.5.4-1.fc6.i386 に必要とされています
kdebase >= 6:3.5.4 は (インストール済み)kdeaddons-3.5.4-1.fc6.i386 に必要とされています
kdebase >= 6:3.5.4 は (インストール済み)kdeartwork-3.5.4-1.fc6.i386 に必要とされています
kdebase >= 6:3.5.4 は (インストール済み)kdeaccessibility-3.5.4-1.fc6.i386 に必要とされています
kdebase = 6:3.5.4-18.el5.centos は (インストール済み)kdebase-devel-3.5.4-18.el5.centos.i386 に必要とされています

となります

全て アンインストール必要でしょうか?
記事編集 編集
Re: samba smb.conf について このメッセージに返信する
日時: 2009/02/05 02:50
名前: stranger
URL: http://ja.528p.com/
rpmまたはyumで削除しないと
rpmのデータベースに情報が残っているので
yum installを実行しても、インストールされない
samba-commonを手動でダウンロードして
強制(上書き)インストールする
rootになって
rpm -ivh --force samba-common*

または空のディレクトリにsamba-commonをコピーして
rpm2cpio samba-common* | cpio -id
を実行してインストールせずに、rpmを展開し
/etc/sambaを/etcにコピーする
所有者をroot:rootに変更する
記事編集 編集
Re: samba smb.conf について このメッセージに返信する
日時: 2009/02/05 08:02
名前: dan
URL:
>rpmまたはyumで削除しないと
>rpmのデータベースに情報が残っているので
>yum installを実行しても、インストールされない
>samba-commonを手動でダウンロードして
>強制(上書き)インストールする
>rootになって
>rpm -ivh --force samba-common*
>
>または空のディレクトリにsamba-commonをコピーして
>rpm2cpio samba-common* | cpio -id
>を実行してインストールせずに、rpmを展開し
>/etc/sambaを/etcにコピーする
>所有者をroot:rootに変更する

rpm -ivh --force samba-common-3.0.28-1.el5_2.1
とすると、
エラー: samba-common-3.0.28-1.el5_2.1 のオープンに失敗: そのようなファイルやディレクトリはありません
DVDからsamba-common これをインストールしましたが smb.confは復活しません。
記事編集 編集
Re: samba smb.conf について このメッセージに返信する
日時: 2009/02/05 09:55
名前: aki
URL:
yum -y remove で、全て確実に削除してから再インストールしてみてください
記事編集 編集
Re: samba smb.conf について このメッセージに返信する
日時: 2009/02/05 09:03
名前: dan
URL:
>yum -y remoe で、全て確実に削除してから再インストールしてみてください
>

ありがとうございます
yum -y remove samba-common-3.0.28-1.el5_2.1
で完全に削除し

yum -y install samba-common-3.0.28-1.el5_2.1
で smb.conf が復活しました。

記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -