このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

公開WEBサーバーの画像やスタイルシートが反映表示されない このメッセージに返信する
日時: 2010/10/28 21:56
名前: みんみん
URL:
初めまして、よろしくお願いします。

ここを見て公開用のWEBサーバーを構築したのですが、
内部からは見れるのですが、外部から見ると、ブラウザのタブの部分に、
サイトのタイトルやメタキーワードは表示されるものの、
HTMLの表示領域には何も表示されない状態です。

このURL http://www.cman.jp/network/support/port.html のサイトを使い、
80番ポートの確認をしたところOKと表示されました。

ですが、このURL http://www.cman.jp/network/support/http.html のサイトから
ホームページのチェックを行うと、上記のような状態になります。

試しに、自分の携帯からサイトを見ると、テキストは表示されるものの、
画像は全っく表示されず、リンクをクリックしてもページが飛ばない状態です。

indexファイルがphpなので、それが悪いのかと思い、
このURL http://centos.server-manual.com/centos5_apache2_php5.html も参考にして
設定をしてから再起動して見ましたが、やはり改善されません。

しかし、こちらのサイトにある通り、test.phpを作り、直接URLで指定すると、
phpinfo()が表示されます。

/var/www/html/の所有権は、
chown -R apache:apache /var/www/html/*
にしてあります。

自分で調べたところ、このURL http://yasuda.iobb.net/wordpress/?p=230 の方と
症状が似ているのですが、私の場合はどのファイルを弄れば良いのか分からない状態です。

お手数をお掛けしますが、お分かりになる方がおられましたら、宜しくお願いします。
記事編集 編集

Page: | 1 | 2 | 3 |

Re: 公開WEBサーバーの画像やスタイルシートが反映表示されない このメッセージに返信する
日時: 2010/10/28 23:16
名前: みんみん
URL:
追記です。

DDNSで非固定IP、独自ドメインは取得済みです。
BINDの設定も終わっております。

パーミッションも全て777にする等を試したのですが改善されません。


画像は、URLで直接ファイルを指定すれば見れるのですが、
index.phpには表示されません・・・。

すいませんが宜しくお願い致します。
記事編集 編集
Re: 公開WEBサーバーの画像やスタイルシートが反映表示されない このメッセージに返信する
日時: 2010/10/28 23:40
名前: とおる
URL:
まず、サーバーが原因か、PHP出力が原因か切り分けしてみたらどうですか?

phpではなく、HTMLファイルで画像を呼び出してみるとか。

記事編集 編集
Re: 公開WEBサーバーの画像やスタイルシートが反映表示されない このメッセージに返信する
日時: 2010/10/28 23:47
名前: みんみん
URL:
>まず、サーバーが原因か、PHP出力が原因か切り分けしてみたらどうですか?
>
>phpではなく、HTMLファイルで画像を呼び出してみるとか。
>
>

ご返信ありがとうございます。

早速、test.htmlを作成し、<img src="">で相対パスで呼び出したところ、
無事に表示されました。
また、同時に文字コードをUTF-8で テスト と書き込んだものも表示されました。

やはりPHPの出力に問題があるのでしょうか?
使っているPHPは5.2.14です。

CMSを使用しており、var/www/html/にindex.phpが作成されている状態です。
CMSから見たPHPのルートは/usr/bin/local/phpとなっており、
内部からは正常に動作しております。

他に何かご指摘がありましたらご教授の程、宜しくお願い致します。
記事編集 編集
Re: 公開WEBサーバーの画像やスタイルシートが反映表示されない このメッセージに返信する
日時: 2010/10/28 23:52
名前: ...
URL:
SELinuxは?
記事編集 編集
Re: 公開WEBサーバーの画像やスタイルシートが反映表示されない このメッセージに返信する
日時: 2010/10/28 23:56
名前: みんみん
URL:
>SELinuxは?

ご返信ありがとうございます。

[root@xxx~]# getenforce
Disabled

と表示されております。

確かCentOSをインストールし、初期の段階で
[root@xxx~]# setenforce 0
を行いました。

本来ならば Permissive と表示されなくてはいけないのですよね?
Disabled でも意味は同じだと思うのですが、どこかまずいところがありますでしょうか?
記事編集 編集
Re: 公開WEBサーバーの画像やスタイルシートが反映表示されない このメッセージに返信する
日時: 2010/10/28 23:56
名前: とおる
URL:
もうしわけありません。
私。PHPはまったくわからないんです。

phpで単純な画像呼び出しプログラムを書いてテストしてみて、
画像が表示されれば、そのCMSに問題があると思います。

私が言えるのはこの程度です。
お力になれずすいません。

PS.差し支えなければ、CMSの名前を入れておくと
どなたからかアドバイスをしてもらえるかもしれません。
記事編集 編集
Re: 公開WEBサーバーの画像やスタイルシートが反映表示されない このメッセージに返信する
日時: 2010/10/29 00:00
名前: みんみん
URL:
>もうしわけありません。
>私。PHPはまったくわからないんです。
>
>phpで単純な画像呼び出しプログラムを書いてテストしてみて、
>画像が表示されれば、そのCMSに問題があると思います。
>
>私が言えるのはこの程度です。
>お力になれずすいません。
>
>PS.差し支えなければ、CMSの名前を入れておくと
>どなたからかアドバイスをしてもらえるかもしれません。
>

大変失礼を致しました。
使用しているCMSはClipBucketと言うCMSで、バージョンは2.0.91です。
記事編集 編集

Page: | 1 | 2 | 3 |

件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -