このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

OpenPNEセットアップ後反応がありません このメッセージに返信する
日時: 2008/06/02 17:39
名前: たこすけ
URL:

OpenPNEについて質問です。
OSはCentOS5.1を入れています。

http://centossrv.com/openpne.shtmlを参考にしてセットアップを行いました。
最新版が2.12.0にアップデートされていたので、それに読み替えインストール終了後、
http://サーバー名/openpne/?m=setupにてセットアップを行い、
「セットアップは終了しました」と出たので、早速admin画面に入ろうと
http://サーバー名/openpne/?m=admin
打ち込んだのですが、反応がないというか読み込めません。
http://サーバー名/openpne/
で表示をさせようとしても同様に読み込めません。
試しに
http://サーバー名/openpne/?m=setup
をしてみると、
「現在、サーバが混み合っているか、メンテナンス中です。
ご迷惑をおかけいたしますが、しばらく時間を空けて再度アクセスしてください。 」
というエラーが出てしまいます。

Webサーバー+PHP、Webサーバー間通信内容暗号化、MySQLデータベースは構築してあります。
PostFixは構築していません。

MySQLのユーザとデータベースも削除して最初からやりなおしましたが、うまくいきません。

どなたか解決方法に心当たりのある方、アドバイスをいただけませんでしょうか。
記事編集 編集
Re: OpenPNEセットアップ後反応がありません このメッセージに返信する
日時: 2008/06/02 18:22
名前: たこすけ
URL:
自己解決しました。
SSLの設定を、内容を精査せずに単にコピペしたせいで、
SSLがきちんと通っていませんでした。

まずはOpenPNEのSSLの設定を「true」→「false」にしたらログインできるようになり、
友人からのアドバイスで間違いを発見しました。

お騒がせしました。
記事編集 編集
追記 このメッセージに返信する
日時: 2008/06/02 18:53
名前: たこすけ
URL:
私が間違えてしまった箇所は、

http://centossrv.com/openpne.shtml

のapache設定のところで、

以下はバーチャルホストでSSL=httpsでアクセスできるようにする場合のみ
[root@linux ~]# vi /etc/httpd/conf.d/ssl.conf ← WebサーバーSSL設定ファイル編集
# Per-Server Logging:
# The home of a custom SSL log file. Use this when you want a
# compact non-error SSL logfile on a virtual host basis.
CustomLog logs/ssl_request_log \
"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteLog "logs/rewrite_log"
RewriteLogLevel 0
RewriteCond %{HTTP_HOST} !centossrv.com$
RewriteCond %{REQUEST_URI} !^/openpne/ ← 追加
RewriteRule ^/(.*)?$ http://%{HTTP_HOST}/$1 [L,R]
</IfModule>
</VirtualHost>

のところで、下から4行目を書き換える必要に気づけませんでした。
ご迷惑をおかけしました。
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -