このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

再起動したらGRUBに落ちた このメッセージに返信する
日時: 2008/03/19 16:19
名前:
URL:
こんにちは

サーバーを再起動する必要があって、再起動したところ、GRUB画面に
落ちてしまい、色々試しても起動しなくなってしまったので、しかたなく、
再インストールをして、yum -y update して、アップデートした後に、
再起動した所、また、GRUB画面に落ちる現象になってしまいました。
さらに、また、再インストールしても、GRUB画面に落ちてしまうのです。

同じような症状になり、解決方法があるという方、おりませんでしょうか?

記事編集 編集
Re: 再起動したらGRUBに落ちた このメッセージに返信する
日時: 2008/03/19 17:02
名前:
URL:

とりあえず、起動しました。

以下のようにして、

grub> root (hd0,0)

Filesystem type is xfs, partition type 0x83

grub> setup (hd0)

grub> reboot

これで、起動しましたが、不安が残ります。
なぜ、この様になってしまったのかが不明です。

記事編集 編集
Re: 再起動したらGRUBに落ちた このメッセージに返信する
日時: 2008/03/19 17:40
名前:
URL:

ちょっと進展、

アップデートで、kernel-2.6.18-53.1.14.el5がインストールされると、
起動しなくなります。(おそらく)

記事編集 編集
Re: 再起動したらGRUBに落ちた このメッセージに返信する
日時: 2008/03/20 00:05
名前: Taq
URL: http://inspiron-web.com/
あ 様

こんばんわ。
一昨日、CentOS5.1をFTPでインストールしただけのマシンがあったので
さっそくyum -y updateして
kernel-2.6.18-53.el5からkernel-2.6.18-53.1.14.el5へアップデートしましたが
特に問題なく起動しています。

時折、カーネルやバージョンに起因してインストールできない、
起動できないなどのトラブルが生じることがあります。
(経験的には440BXチップ上でPCI接続したNICがCentOS5.xで正常に動作しないとか。ドライバの問題?)

あ様の場合、必ずしもハードウェアに起因する問題ではないのかもしれませんが、
もし他に利用可能なハードウェアがあるのであれば、
他のハードウェアでインストール及びアップデートのテストしてみるのも
このBBS上で情報共有すると言った意味合いではおもしろいかもしれません。

以上、ご参考までに。
記事編集 編集
Re: 再起動したらGRUBに落ちた このメッセージに返信する
日時: 2008/03/20 21:22
名前: かわせみ!
URL: http://kwne.jp/
こんにちは。かわせみ!と申します。
当方は、kernel-2.6.18-53.1.4.el5からkernel-2.6.18-53.1.14.el5へアップデートした途端。。。
運用しているサーバーからの応答が悪く、重い感じで使えない状態になりました。
古いkernelだと安定して運用出来るのでkernelの問題かなぁ。。。と思っております。
次のkernelにて安定してくれる事を期待しています。
ちなみにハード構成は、GXチップにPEN3-450MHzといった所です。。。
情報まで。。。
記事編集 編集
Re: 再起動したらGRUBに落ちた このメッセージに返信する
日時: 2008/03/21 22:39
名前: 通りすがりの初心者
URL:

当方DELLのpcを使用してるのですが
DELLでしたらDELLのHPに対策方法が載ってますが・・・
それぞれのメーカーによって対処方法が違うようです
DELL機でしたら ご連絡ください
当方 再度installより行ってます(yum -y updateをまで実行してません)ので 御指摘できる環境にありません
が 大体の事でしたらご連絡させていただきますが あくまで 大体ですのでご了承下さい。

では、
記事編集 編集
Re: 再起動したらGRUBに落ちた このメッセージに返信する
日時: 2008/03/24 10:00
名前:
URL:

Taq様、かわせみ!様、通りすがりの初心者様、ありがとうございます。

色々と、調べましたところ、RAID1で運用していると、Kernelのアップデート時
に、GRUBの書き込みに失敗するという事が判明し、RAIDカードを新たに購入し
て、RAIDを組むという形態にして、サーバーの再構築を行ったところ、正常に
動くようになりました。

記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -