このスレッドは未解決です(解決したらこちらで解決済にしてください)
<<戻る

CGIで教えてください。 このメッセージに返信する
日時: 2007/09/25 19:18
名前: LR
URL:
あるCGIをCENT4.5/Fedora4などで動作させると正常に動作します。
ところが、CENT5やFedora5以降で、このCGIを動作させると、
画面は表示されるのですが、CGIのソースが一部表示される現象がでます。

print EOF<<

EOF

で、囲んだ部分など。ヒアドキュメントの個所。
これは、PERLのバージョンが異なるからこういうふうにでるのでしょうか?
CENT5やFedora5以降は、PERL5.8系?
CENT4.5やFEDORA4などは、PERL5.6なのでしょうか?

ちなみに、CENT5に、あえてPERL5.6を、usr/local/bin/perl に入れてみたのですが、
結果はだめでした・・・。

CENT5などで、このCGIを使用するのは不可能なのでしょうか???




記事編集 編集
Re: CGIで教えてください。 このメッセージに返信する
日時: 2007/09/26 00:23
名前: 愚者
URL:
あるCGIの動作する環境等が書かれていないので、誰もお答えできないと思いますが。
・どこから入手できるものか
・動作させるための仕様(perlのverやその他)
等を記載してみてはいかがでしょうか。
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -