このスレッドは未解決です(解決したらこちらで解決済にしてください)
<<戻る

phpの再インストール後に現れたエラー このメッセージに返信する
日時: 2007/03/04 17:34
名前: 高田
URL:

はじめまして、高田と申します。

CentOSのphpをアンインストールして
ソースにてコンパイルし直した時にエラーが現れ困っております。
原因または解決策をご存じの方はいらっしゃいませんでしょうか。

環境は
CentOS4.4
php5.16 -> php 5.2.1

私の行った手順は以下です。

・yum remove "php*"
でデフォルトのphp関連をアンインストール

・5.2.1のソースをダウンロードしてコンパイル、インストール
長いですが一応configureも掲載します。
'./configure' --with-pgsql '--build=i686-redhat-linux-gnu
' '--host=i686-redhat-linux-gnu' '--target=i386-redhat-linux-gnu' '--program-pre
fix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/s
bin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--l
ibdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstat
edir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-fi
le=../config.cache' '--with-libdir=lib' '--with-config-file-path=/etc' '--with-c
onfig-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath'
'--without-pear' '--with-bz2' '--with-curl' '--with-exec-dir=/usr/bin' '--with-
freetype' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp
' '--with-iconv' '--with-openssl' '--with-pspell' '--with-expat-dir=/usr' '--wit
h-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-f
tp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysv
shm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-yp'
'--enable-wddx' '--with-kerberos' '--enable-ucd-snmp-hack' '--with-unixODBC=sha
red,/usr' '--enable-memory-limit' '--enable-shmop' '--enable-calendar' '--enable
-dbx' '--enable-dio' '--with-mime-magic=/etc/httpd/conf/magic' '--without-sqlite
' '--with-libxml-dir=/usr' '--with-xml' '--with-apxs2=/usr/sbin/apxs' '--with-my
sql' '--with-gd' '--without-odbc' '--disable-dom' '--disable-dba' '--without-uni
xODBC' '--disable-pdo' '--disable-xmlreader' '--disable-xmlwriter' '--with-mcryp
t' '--with-png-dir=/usr' '--with-jpeg-dir' --enable-mbstring --enable-mbstr-enc-
trans

・apacheの設定に以下を追加
LoadModule php5_module /usr/lib/httpd/modules/libphp5.so
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

・php.iniの修正
extension_dir = "./"
から
extension_dir = "/usr/lib/php/"



上記の後、ファイル内が
<?php phpinfo();
のファイルでも、最後に以下のようなエラーが現れてしまいます。
Fatal error: Nesting level too deep - recursive dependency? in Unknown on line 0
既存のプログラムはまともに表示されない、もしくは空白の状態です。

色々と調べて
http://bugs.php.net/bug.php?id=5489
http://bugs.php.net/bug.php?id=21333
等を発見したのですが、
どうもなおる様子もなく困っております。
(惜しいと思ったのですが、
extension_dirがもともと空でした。
何か他にずれているものがあるのかもしれません)


何かご存じの方、もしくは解決法案などございましたら
ご教授いただければと思います。
記事編集 編集
Re: phpの再インストール後に現れたエラー このメッセージに返信する
日時: 2007/03/05 01:05
名前: 高田
URL:
すみません、自己解決致しました。

configure & makeを色々試していたのが行けなかったようです。
make clean
make
で解決致しました。
記事編集 編集
オークリー サングラス 人気 このメッセージに返信する
日時: 2013/07/31(Wed) 03:44
名前: 449825
URL: http://oakleysunglasseshot.tumblr.com/
美姫さん、管理人の皆様、いつもありがとうございます。アイスショーお疲れ様でした。どんどん、良くなっていくあなたの回復の凄さに驚かされています。 今日、とてもショックな記事を読みました。テクニカルの条件として五種類のトリプルを跳ぶ事が必要なんて。こんな話聞いたことありません。強化選手、全てが五種類のジャンプを完璧に跳べるのでしょうか。じゃあ、皆、優勝ですよね??? 少なくともミニマムポイントをクリアし、それなりの形が整えば、とりあえず強化選手に復帰させるか、さもなければ、B級の国際大会への派遣を検討してしかるべきです。平等って何でしょう。今までそうした強化指定をしても伸び悩んだり、結果が出せない人は沢山います。そして一度、落選すると決して「救済の手」を差し伸べないのが連盟のやりかた。別に美姫さんを特別扱いしろなんて言ってない。国際スケート連盟のやりかたにのっとって進行して欲しいだけ。 一寸興奮しているのですが、考えてみれば美姫さんが今後の大会でばっちり、トリプルを跳んでしまえばOKなんですよね。二つの大会でとにかく表彰台に上がり、連盟をぎゃふんと言わせて!!!!!!。がっつり、明日をくだせえ!(長渕剛 笑)です。 大丈夫ですよ、多分美姫さんは、こういう状況の方が燃えるでしょうね。何度も嫌な目、つらい目にあってきたけれどいつも復活してきました。どんな事があっても後押ししている人達の事忘れないで。無茶な事は百も承知だけれど、筋肉や体のの状態が戻り、精神的に安定さえすれば、あなたはどんな状況でも戦える人ですものね。本当の美姫さんはとっても強い人なんです。あなたの心の奥底には自分でも知らない強靭で逞しく、そして誰よりも美しい魂が潜んでいます。あなたの才能を全て出し尽くしたとは思っていません。まだ、開花すべき才能が潜んでいる。本当のあなたはまだ、姿を見せていないのです。 あんまり、頑張れ、なんて言いません。でもきっと奇跡は起こる。あなたならやってくれる。何だか勝手にそんな気持ちになってしまいました。 でも、無理も、無茶もダメですよ。でも出来ることをひとつひとつ。お子さんやご家族との絆を大切にして、明るい気持ちでアメリカでの振付けをしてくださいね! オークリー サングラス 人気 http://oakleysunglasseshot.tumblr.com/
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -