このスレッドは未解決です(解決したらこちらで解決済にしてください)
<<戻る

SSHサーバー構築(OpenSSH)でエラーが このメッセージに返信する
日時: 2013/10/20(Sun) 11:19
名前: アサピーファン
URL:
 CentOS6.4(64bit)で、ここの "SSHサーバー構築(OpenSSH)"を参考にして、SSHバージョンの6.3p1をリビルドしようとしたら以下のエラーが出てしまいました。
 
[root@xxxx ~]# rpmbuild -tb --clean openssh-6.3p1.tar.gz
警告: line 24: prereq is deprecated: PreReq: openssl
警告: line 34: buildprereq is deprecated: BuildPrereq: openssl
警告: line 35: buildprereq is deprecated: BuildPrereq: tcpd-devel
警告: line 36: buildprereq is deprecated: BuildPrereq: zlib-devel
警告: line 49: buildprereq is deprecated: BuildPrereq: XFree86-devel
エラー: ファイル /root/x11-ssh-askpass-1.2.4.1.tar.gz: そのようなファイルやディレクトリはありません

 これってどういうことでしょうか?
 どうか、よろしくお願い致します。
記事編集 編集
Re: SSHサーバー構築(OpenSSH)でエラーが このメッセージに返信する
日時: 2013/10/20(Sun) 11:38
名前: stranger
URL: http://ja.528p.com/
http://pkgs.fedoraproject.org/repo/pkgs/openssh/
にあるのでダウンロードしてrootディレクトリに置く

ここのサイトの参考例のようにspecファイルで
%define no_x11_askpass 1
%define no_gnome_askpass 1
に設定しておけば無視されるのでは?

警告:
はrpmbuildの仕様の問題で無視してもいいように思うけど
いやなら specファイルの
PreReq:

Requires(pre):

BuildPreReq:

BuildRequires(pre):
に修正します
記事編集 編集
Re: SSHサーバー構築(OpenSSH)でエラーが このメッセージに返信する
日時: 2013/10/20(Sun) 13:23
名前: アサピーファン
URL:
strangerさん ありがとうございます。

解決できました。

>http://pkgs.fedoraproject.org/repo/pkgs/openssh/
>にあるのでダウンロードしてrootディレクトリに置く
>
>ここのサイトの参考例のようにspecファイルで
>%define no_x11_askpass 1
>%define no_gnome_askpass 1
>に設定しておけば無視されるのでは?
>
>警告:
>はrpmbuildの仕様の問題で無視してもいいように思うけど
>いやなら specファイルの
>PreReq:
>を
>Requires(pre):
>
>BuildPreReq:
>を
>BuildRequires(pre):
>に修正します
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -