このスレッドは未解決です(解決したらこちらで解決済にしてください)
<<戻る

IO::Socket::SSLインストール このメッセージに返信する
日時: 2011/08/22 13:13
名前: タカ
URL:

恐れ入ります。
ddclientを使う上で、
IO::Socket::SSLが必要だということで、
CPANからインストールを試みたのですが、

t/local/06_tcpecho.t ........... Use of uninitialized value in string eq at t/local/06_tcpecho.t line 50

と出て止まってしまいます。
原因が分かる方、よろしくお願いします。
記事編集 編集
Re: IO::Socket::SSLインストール このメッセージに返信する
日時: 2011/08/22 14:55
名前: una
URL:
原因は分かりませんが簡単に片付けるならRPMforgeのリポジトリが追加済みであれば
yum -y install perl-IO-Socket-SSL でインストールできます。
ちなみにddclientのrpmパッケージもあるのでddclientをyumで入れると
perl-IO-Socket-SSLも勝手に入ります。
記事編集 編集
Re: IO::Socket::SSLインストール このメッセージに返信する
日時: 2011/08/22 15:19
名前: stranger
URL: http://ja.528p.com/
CentOS 5.6なのか6.0なのかわかりませんが
6.0は公式にperl-IO-Socket-SSLをサポートしています
記事編集 編集
Re: IO::Socket::SSLインストール このメッセージに返信する
日時: 2011/08/23 21:09
名前: ペングイン
URL: http://blog.trippyboy.com
タカさん

そのエラー以外の出力に肝心な部分があったりしません?

[root@vps1 ~]# yum search perl-IO-Socket-SSL --enablerepo=base
Loaded plugins: priorities
Excluding Packages in global exclude list
Finished
========================= Matched: perl-IO-Socket-SSL ==========================
perl-IO-Socket-SSL.noarch : Perl library for transparent SSL
[root@vps1 ~]#

CentOS5.6にインストールしているものの依存関係は以下のとおりでした。
[root@vps1 ~]# rpm -qR perl-IO-Socket-SSL-1.01-1.fc6
perl(:MODULE_COMPAT_5.8.8)
perl(Carp)
perl(Errno)
perl(Exporter)
perl(IO::Socket)
perl(Net::SSLeay) >= 1.21
perl(Scalar::Util)
perl(constant)
perl(strict)
perl(vars)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
[root@vps1 ~]#
[root@vps1 ~]# cat /etc/redhat-release
CentOS release 5.6 (Final)
[root@vps1 ~]#
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -