このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

OpenVPNが更新後からエラーでるように このメッセージに返信する
日時: 2011/06/05 21:05
名前: 不知火
URL:
表題の件の通りなのですが、本日OpenVPNがyumで更新された後から、どうもエラーがでるようになりました。
エラーメッセージは
/etc/init.d/openvpn: line 169: script_security---script-security 2: command not found
と起動時に出てしまいます。

現在は、最新版のopenvpnパッケージ
openvpn.x86_64 2.2.0-2.el5.rfになっています。

https://forums.openvpn.net/topic8269.htmlこちらのフォーラムでも話がでていますが、openvpn.origから修正したような記録がありますが、上手くいきません。

openvpn.origファイルがなかったのでopenvpn.rpmsaveの事を指してるのではないかと解釈し、
diff -u /etc/init.d/openvpn.rpmsave /etc/init.d/openvpn
と入力しました。
openvpnのデーモンを再起動するもやはり同じエラーメッセージとなり途方に暮れてます。

わかる方いらっしゃいましたら、ご教示願えませんでしょうか?宜しくお願いします。
記事編集 編集
Re: OpenVPNが更新後からエラーでるように このメッセージに返信する
日時: 2011/06/05 23:09
名前: よっしー
URL: https://takao-y.net/~takao/fswiki/wiki.cgi
こんばんは、お世話になります。

不知火さん>
書き込みの内容を拝見し、私もかねてから最新のOpenVPNのインストールを
考えていたのでこれを機会に同じ最新版をインストールしたところ、
全く同じエラーに遭遇し、記載なさっていたOpenVPNのフォーラム
の書き込みを参考に下記手順で解決しました。(^o^)

1. cd /etc/init.dを実行
2. cp openvpn openvpn.origを実行
3. touch openvpn.patchを実行し、その後不知火さんご指摘のOpenVPNのフォーラムの記事にあった
  下記内容をopenvpn.patchにviコマンドで書き込み(=ペーストして)、保存

--- /etc/init.d/openvpn.orig 2011-05-23 15:01:04.000000000 -0600
+++ /etc/init.d/openvpn 2011-06-05 05:04:15.000000000 -0600
@@ -166,7 +166,7 @@
# Handle backward compatibility, see Red Hat Bugzilla ID #458594
script_security=''
if [ -z "$( grep '^[[:space:]]*script-security[[:space:]]' $c )" ]; then
- script_security-"--script-security 2"
+ script_security="--script-security 2"
fi
$openvpn --daemon --writepid $piddir/$bn.pid --config $c --cd $work $script_security
if [ $? = 0 ]; then

4. patch -p1 < openvpn.patchを実行し、File to patch:のプロンプトが出たら、openvpnと入力してEnterキーを押下
5. rm openvpn.origとrm openvpn.patchで不用なファイルを削除

以上です。上記対応の後、openvpnサービス再起動でエラー無く当該サービスを起動出来ました。
尚、本件は先のフォーラムの当該記事の最後にバグ(OpenVPNの起動スクリプトの記述ミス?)
と書かれているので、おそらくは次期OpenVPNのバージョンでは修正されるのではないかと・・・。

宜しくお願い致します。

以上
記事編集 編集
Re: OpenVPNが更新後からエラーでるように このメッセージに返信する
日時: 2011/06/06 00:59
名前: 不知火
URL:
>こんばんは、お世話になります。
>
>不知火さん>
>書き込みの内容を拝見し、私もかねてから最新のOpenVPNのインストールを
>考えていたのでこれを機会に同じ最新版をインストールしたところ、
>全く同じエラーに遭遇し、記載なさっていたOpenVPNのフォーラム
>の書き込みを参考に下記手順で解決しました。(^o^)

同じ境遇の方が居て助かりました、丁寧にしっかりとした手順もお書きして頂き恐縮です_orz
この掲示板に来ると、stranger様とよっしー様にいつも助けられており恐縮です(´・ω・`)

>以上です。上記対応の後、openvpnサービス再起動でエラー無く当該サービスを起動出来ました。
>尚、本件は先のフォーラムの当該記事の最後にバグ(OpenVPNの起動スクリプトの記述ミス?)
>と書かれているので、おそらくは次期OpenVPNのバージョンでは修正されるのではないかと・・・。

私もお教え頂いた手順で同じく直りました、ありがとうございます。
どうも、今回のバージョンのバグのような事が英語で書かれてましたね…
また、お世話になることもあるかもしれませんが、その時は宜しくお願いしますm(_ _)m
記事編集 編集
Re: OpenVPNが更新後からエラーでるように このメッセージに返信する
日時: 2011/06/07 12:03
名前: 管理人
URL:
不知火様
よっしー様

不具合のご報告および対処手順の書き込みありがとうございます。
http://centossrv.com/openvpn.shtml
も修正しておきました。
記事編集 編集
Re: OpenVPNが更新後からエラーでるように このメッセージに返信する
日時: 2011/06/11 20:49
名前: よっしー
URL: https://takao-y.net/~takao/fswiki/wiki.cgi
こんばんは、お世話になります。

管理人 様、不知火さん>
昨日リリースされた?openvpn-2.2.0-3.el5.rfで
本件の修正(OpenVPNの起動スクリプトの修正)
が行われたようです。

宜しくお願い致します。

以上
記事編集 編集
オークリー サングラス 度付き このメッセージに返信する
日時: 2013/07/30(Tue) 16:22
名前: 542901
URL: http://oakleysunglasseshot.tumblr.com/
まず映画「ソーシャル・ネットワーク」を観た方がよろしいでしょうか?(^-^) オークリー サングラス 度付き http://oakleysunglasseshot.tumblr.com/
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -