このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

PHPがインストールできません このメッセージに返信する
日時: 2011/04/19 22:35
名前: つばさ
URL:
CentOS 5.6にしたら
PHPがインストール出来なくなりました
yum list php53*
Loaded plugins: fastestmirror, priorities
Repository dag is listed more than once in the configuration
Loading mirror speeds from cached hostfile
* addons: ftp.iij.ad.jp
* base: ftp.iij.ad.jp
* extras: ftp.iij.ad.jp
* updates: ftp.iij.ad.jp
192 packages excluded due to repository priority protections
Available Packages
php53.i386 5.3.3-1.el5_6.1 updates
php53-bcmath.i386 5.3.3-1.el5_6.1 updates
php53-cli.i386 5.3.3-1.el5_6.1 updates
php53-common.i386 5.3.3-1.el5_6.1 updates
php53-dba.i386 5.3.3-1.el5_6.1 updates
php53-devel.i386 5.3.3-1.el5_6.1 updates
php53-eaccelerator.i386 1:0.9.6.1-1.el5_2.wing wing
php53-eaccelerator-selinux.i386 1:0.9.6.1-1.el5_2.wing wing
php53-embedded.i386 5.3.6-2.el5_2.wing.1 wing
php53-enchant.i386 5.3.6-2.el5_2.wing.1 wing
php53-gd.i386 5.3.3-1.el5_6.1 updates
php53-imap.i386 5.3.3-1.el5_6.1 updates
php53-intl.i386 5.3.3-1.el5_6.1 updates
php53-ldap.i386 5.3.3-1.el5_6.1 updates
php53-mbstring.i386 5.3.3-1.el5_6.1 updates
php53-mcrypt.i386 5.3.6-2.el5_2.wing.1 wing
php53-mssql.i386 5.3.6-2.el5_2.wing.1 wing
php53-mysql.i386 5.3.3-1.el5_6.1 updates
php53-odbc.i386 5.3.3-1.el5_6.1 updates
php53-pdo.i386 5.3.3-1.el5_6.1 updates
php53-pecl-xdebug.i386 2.1.1-1.el5_1.wing wing
php53-pgsql.i386 5.3.3-1.el5_6.1 updates
php53-process.i386 5.3.3-1.el5_6.1 updates
php53-pspell.i386 5.3.3-1.el5_6.1 updates
php53-recode.i386 5.3.6-2.el5_2.wing.1 wing
php53-snmp.i386 5.3.3-1.el5_6.1 updates
php53-soap.i386 5.3.3-1.el5_6.1 updates
php53-tidy.i386 5.3.6-2.el5_2.wing.1 wing
php53-xcache.i386 1:1.3.1-1.el5_2.wing wing
php53-xcache-selinux.i386 1:1.3.1-1.el5_2.wing wing
php53-xml.i386 5.3.3-1.el5_6.1 updates
php53-xmlrpc.i386 5.3.3-1.el5_6.1 updates
php53-zts.i386            5.3.6-2.el5_2.wing.1 wing

yum install php53 php53-devel php53-mbstring php53-mysql php53-pdo php53-xml php53-gd
Loaded plugins: fastestmirror, priorities
Repository dag is listed more than once in the configuration
Loading mirror speeds from cached hostfile
* addons: ftp.iij.ad.jp
* base: ftp.iij.ad.jp
* extras: ftp.iij.ad.jp
* updates: ftp.iij.ad.jp
192 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php53.i386 0:5.3.3-1.el5_6.1 set to be updated
--> Processing Dependency: php53-cli = 5.3.3-1.el5_6.1 for package: php53
--> Processing Dependency: php53-common = 5.3.3-1.el5_6.1 for package: php53
---> Package php53-devel.i386 0:5.3.3-1.el5_6.1 set to be updated
--> Processing Dependency: autoconf for package: php53-devel
--> Processing Dependency: automake for package: php53-devel
---> Package php53-gd.i386 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-mbstring.i386 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-mysql.i386 0:5.3.3-1.el5_6.1 set to be updated
--> Processing Dependency: libmysqlclient.so.15 for package: php53-mysql
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package: php53-mysql
---> Package php53-pdo.i386 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-xml.i386 0:5.3.3-1.el5_6.1 set to be updated
--> Running transaction check
---> Package autoconf.noarch 0:2.59-12 set to be updated
--> Processing Dependency: imake for package: autoconf
---> Package automake.noarch 0:1.9.6-2.3.el5 set to be updated
---> Package php53-cli.i386 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-common.i386 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-mysql.i386 0:5.3.3-1.el5_6.1 set to be updated
--> Processing Dependency: libmysqlclient.so.15 for package: php53-mysql
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package: php53-mysql
--> Running transaction check
---> Package imake.i386 0:1.0.2-3 set to be updated
---> Package php53-mysql.i386 0:5.3.3-1.el5_6.1 set to be updated
--> Processing Dependency: libmysqlclient.so.15 for package: php53-mysql
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package: php53-mysql
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-mysql-5.3.3-1.el5_6.1.i386 from updates has depsolving problems
--> Missing Dependency: libmysqlclient.so.15 is needed by package php53-mysql-5.3.3-1.el5_6.1.i386 (updates)
php53-mysql-5.3.3-1.el5_6.1.i386 from updates has depsolving problems
--> Missing Dependency: libmysqlclient.so.15(libmysqlclient_15) is needed by package php53-mysql-5.3.3-1.el5_6.1.i386 (updates)
php53-common-5.3.3-1.el5_6.1.i386 from updates has depsolving problems
--> php53-common conflicts with php-common
Error: Missing Dependency: libmysqlclient.so.15 is needed by package php53-mysql-5.3.3-1.el5_6.1.i386 (updates)
Error: Missing Dependency: libmysqlclient.so.15(libmysqlclient_15) is needed by package php53-mysql-5.3.3-1.el5_6.1.i386 (updates)
Error: php53-common conflicts with php-common
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
アパッチを停止後 phpをアンインストールしたきり インストールを受け付けてくれなくなりました
記事編集 編集

Page: | 1 | 2 |

Re: PHPがインストールできません このメッセージに返信する
日時: 2011/04/20 09:28
名前: つばさ
URL:
>OpenPNEを入れているようですが
>php-5.3.xではうまく機能しない部分がでてくることとかは、解決ずみなのですか
>
>php-5.1.xからphp-5.3.xへのupgradeは下記なども見てください
>
>PHP 5.1.x から PHP 5.2.x への移行
>http://php.net/manual/ja/migration52.php
>PHP 5.2.x から PHP 5.3.x への移行
>http://php.net/manual/ja/migration53.php
>
>test段階ならどんどんエラーを出してください
現在 phpは動作しません
PHPソースが表示されてしまう状態です
自分なりに調べてみたのですが
/etc/yum.repos.d/dag.repo これがyumに関係するようなのですが
現在
[dag]
name=CentOS-$releasever - Dag
baseurl=http://ftp.riken.jp/Linux/dag/redhat/el$releasever/en/$basearch/dag
gpgcheck=1
enabled=0
gpgkey=http://dag.wieers.com/packages/RPM-GPG-KEY.dag.txt
となっております

記事編集 編集
Re: PHPがインストールできません このメッセージに返信する
日時: 2011/04/20 09:49
名前: つばさ
URL:
>phpもmysqlも入っていない環境で
>yum install php53 php53-devel php53-mbstring php53-mysql php53-pdo php53-xml php53-gd
>を実行したら
>Total download size: 11 M
>Is this ok [y/N]:
>まで進みましたけど
>
>ldconfig -p | grep libmysqlclient
>
>でlibmysqlclient.so.15が表示されない場合
>mysql-5.0.x関連パッケージが入っていない
>
>libmysqlclient.so.16と表示されたら
>mysql-5.1.xが入っている
>
ldconfig -p | grep libmysqlclient
libmysqlclient_r.so.16 (libc6) => /usr/lib/mysql/libmysqlclient_r.so.16
libmysqlclient_r.so (libc6) => /usr/lib/mysql/libmysqlclient_r.so
libmysqlclient.so.16 (libc6) => /usr/lib/mysql/libmysqlclient.so.16
libmysqlclient.so (libc6) => /usr/lib/mysql/libmysqlclient.so
といった状態です
記事編集 編集
Re: PHPがインストールできません このメッセージに返信する
日時: 2011/04/20 09:59
名前: stranger
URL: http://ja.528p.com/
wingは影響するようですが
dagさんのrpmforgeはyumの実行結果にでていない

--disablerepo=wingを
yum に追加して実行してみたら

yum --disablerepo=wing install php53 php53-devel php53-mbstring php53-mysql php53-pdo php53-xml php53-gd
installしないでエラーが解決するか確認のみ

ldconfig -p | grep libmysqlclient
の結果はどうなりましたか
ついでに
rpm -qa | grep mysql
記事編集 編集
Re: PHPがインストールできません このメッセージに返信する
日時: 2011/04/20 10:13
名前: つばさ
URL:
>wingは影響するようですが
>dagさんのrpmforgeはyumの実行結果にでていない
>
>--disablerepo=wingを
>yum に追加して実行してみたら
>
>yum --disablerepo=wing install php53 php53-devel php53-mbstring php53-mysql php53-pdo php53-xml php53-gd
>installしないでエラーが解決するか確認のみ
>
>ldconfig -p | grep libmysqlclient
>の結果はどうなりましたか
>ついでに
>rpm -qa | grep mysql
yum --disablerepo=wing install php53 php53-devel php53-mbstring php53-mysql php53-pdo php53-xml php53-gd
Loaded plugins: fastestmirror, priorities
Repository dag is listed more than once in the configuration
Loading mirror speeds from cached hostfile
* addons: ftp.iij.ad.jp
* base: ftp.iij.ad.jp
* extras: ftp.iij.ad.jp
* updates: ftp.iij.ad.jp
addons | 951 B 00:00
base | 1.1 kB 00:00
dag | 1.1 kB 00:00
extras | 2.1 kB 00:00
updates | 1.9 kB 00:00
83 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php53.i386 0:5.3.3-1.el5_6.1 set to be updated
--> Processing Dependency: php53-cli = 5.3.3-1.el5_6.1 for package: php53
--> Processing Dependency: php53-common = 5.3.3-1.el5_6.1 for package: php53
---> Package php53-devel.i386 0:5.3.3-1.el5_6.1 set to be updated
--> Processing Dependency: autoconf for package: php53-devel
--> Processing Dependency: automake for package: php53-devel
---> Package php53-gd.i386 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-mbstring.i386 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-mysql.i386 0:5.3.3-1.el5_6.1 set to be updated
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package: php53-mysql
--> Processing Dependency: libmysqlclient.so.15 for package: php53-mysql
---> Package php53-pdo.i386 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-xml.i386 0:5.3.3-1.el5_6.1 set to be updated
--> Running transaction check
---> Package autoconf.noarch 0:2.59-12 set to be updated
--> Processing Dependency: imake for package: autoconf
---> Package automake.noarch 0:1.9.6-2.3.el5 set to be updated
---> Package php53-cli.i386 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-common.i386 0:5.3.3-1.el5_6.1 set to be updated
---> Package php53-mysql.i386 0:5.3.3-1.el5_6.1 set to be updated
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package: php53-mysql
--> Processing Dependency: libmysqlclient.so.15 for package: php53-mysql
--> Running transaction check
---> Package imake.i386 0:1.0.2-3 set to be updated
---> Package php53-mysql.i386 0:5.3.3-1.el5_6.1 set to be updated
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package: php53-mysql
--> Processing Dependency: libmysqlclient.so.15 for package: php53-mysql
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-mysql-5.3.3-1.el5_6.1.i386 from updates has depsolving problems
--> Missing Dependency: libmysqlclient.so.15 is needed by package php53-mysql-5.3.3-1.el5_6.1.i386 (updates)
php53-mysql-5.3.3-1.el5_6.1.i386 from updates has depsolving problems
--> Missing Dependency: libmysqlclient.so.15(libmysqlclient_15) is needed by package php53-mysql-5.3.3-1.el5_6.1.i386 (updates)
php53-common-5.3.3-1.el5_6.1.i386 from updates has depsolving problems
--> php53-common conflicts with php-common
Error: Missing Dependency: libmysqlclient.so.15 is needed by package php53-mysql-5.3.3-1.el5_6.1.i386 (updates)
Error: Missing Dependency: libmysqlclient.so.15(libmysqlclient_15) is needed by package php53-mysql-5.3.3-1.el5_6.1.i386 (updates)
Error: php53-common conflicts with php-common
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package

rpm -qa | grep mysql
freeradius2-mysql-2.1.8-1.el5_1.wing
mysql-5.1.56-1.el5_2.wing
php-mysql-5.2.17-1.el5_0.wing
mysql-libs-5.1.56-1.el5_2.wing
mysql-server-5.1.56-1.el5_2.wing
mysql-devel-5.1.56-1.el5_2.wing
となりました。

記事編集 編集
Re: PHPがインストールできません このメッセージに返信する
日時: 2011/04/20 10:40
名前: stranger
URL: http://ja.528p.com/
mysql-libs-5.1.56-1.el5_2.wingのライブラリが
libmysqlclient.so.16
なのでCentOSのphp53の要求するlibmysqlclient.so.15でないため
エラーになります
wingレポのmysql-5.1.56をCentOSのmysqlにダウングレードするか
wingレポのphp53 (php-5.3.6)を入れるようにする

wingレポを使ったことがないのでどのように動くか解かりません

http://wing-net.ddo.jp/wing/redhat/el5/i386/
記事編集 編集
Re: PHPがインストールできません このメッセージに返信する
日時: 2011/04/20 11:03
名前: つばさ
URL:
>mysql-libs-5.1.56-1.el5_2.wingのライブラリが
>libmysqlclient.so.16
>なのでCentOSのphp53の要求するlibmysqlclient.so.15でないため
>エラーになります
>wingレポのmysql-5.1.56をCentOSのmysqlにダウングレードするか
>wingレポのphp53 (php-5.3.6)を入れるようにする
>
>wingレポを使ったことがないのでどのように動くか解かりません
>
>http://wing-net.ddo.jp/wing/redhat/el5/i386/
有難うございました。
原因は究明されました。
本当にお世話になりました。
もう少し 頑張って 解決するよう努力してみます。
記事編集 編集

Page: | 1 | 2 |

件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -