このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

MySQL、PHPについて このメッセージに返信する
日時: 2010/05/25 18:28
名前: k
URL:
最新のMySQL、最新のPHPでデータベースサーバー構築し最新のphpMyAdminを使用したい。

正式にサポートされてないPHP5.2以後を使いたいと思っている。理由はPHP5.2以後じゃないとソフトウェアが対応してない為。

色々、GoogleやYahoo!でぐぐってみたが、ダウンロード先がリンクが切れており404エラーなので困っている。

予定ではremiの物を使ってyumでやりたいと思っています。

そして、情報が古いためここで聞いてみることにしました。

普通にCentOSでyumでインストールするとPHP 5.2+ is required
ここのサイト通りにやるとPHP 5.2+ is required

教えてくれると有難い。
記事編集 編集
Re: MySQL、PHPについて このメッセージに返信する
日時: 2010/05/26 11:15
名前: ウルグ
URL:
今はcentos5.5でこんな感じですわ。

mysql-5.1.47-1.el5.remi
php-5.3.2-2.el5
httpd-2.2.15-2.el5

ここに全て書いてあるので、古いblogとか鵜呑みするより、
開発元のサイトで見た方が正確でしょうね
http://rpms.famillecollet.com/
全て書いてありますけど…

まぁ、探す事が出来ないかもしれないので…
wget http://rpms.famillecollet.com/enterprise/remi-release-5.rpm
yum --enablerepo=remi update php*


記事編集 編集
Re: MySQL、PHPについて このメッセージに返信する
日時: 2010/05/26 16:27
名前: k
URL:
ありがとうございます

深く考えてました・・。

開発元サイト見て解決しました

記事編集 編集
Re: MySQL、PHPについて このメッセージに返信する
日時: 2010/05/26 23:37
名前: k
URL:
yum --enablerepo=remi update

Loaded plugins: downloadonly, fastestmirror, priorities
Repository remi is listed more than once in the configuration
Loading mirror speeds from cached hostfile
* addons: ftp.tsukuba.wide.ad.jp
* base: ftp.tsukuba.wide.ad.jp
* extras: ftp.tsukuba.wide.ad.jp
* remi: remi-mirror.dedipower.com
* rpmforge: fr2.rpmfind.net
* updates: ftp.tsukuba.wide.ad.jp
596 packages excluded due to repository priority protections
Setting up Update Process
No Packages marked for Update

解決方法教えてくれるとありがたい

PHPはアップグレードされず
記事編集 編集
Re: MySQL、PHPについて このメッセージに返信する
日時: 2010/05/27 10:31
名前: ウルグ
URL:
あれ?
何か色々入れてますか?

yum の yum-prioritiesを入れてたら正常に行かないっす。
baseとか、rpmforgeとかの優先度を下げて、remiを1とかで最優先にしないと…


あと、EPELも入れておいてください。
https://fedoraproject.org/wiki/EPEL/FAQ/Japanese#EPEL_.E3.82.92.E5.88.A9.E7.94.A8.E3.81.99.E3.82.8B

改めて、
yum --enablerepo="remi,epel" update mysql-server
記事編集 編集
Re: MySQL、PHPについて このメッセージに返信する
日時: 2010/05/27 17:20
名前: k
URL:
優先度を変えたのですが

3739 packages excluded due to repository priority protections
Setting up Update Process
No Packages marked for Update

となり、優先度が変わっていない!?

記事編集 編集
Re: MySQL、PHPについて このメッセージに返信する
日時: 2010/05/27 18:43
名前: ウルグ
URL:
http://centossrv.com/patio/patio.cgi?mode=view&no=1763
に統合します。
記事編集 編集
Re: MySQL、PHPについて このメッセージに返信する
日時: 2010/05/27 19:23
名前: k
URL:
Setting up Update Process
Package(s) php* available, but not installed.
No Packages marked for Update

なぜインストールできない?

止めたのだが・・・。
記事編集 編集
Re: MySQL、PHPについて このメッセージに返信する
日時: 2010/06/14 23:53
名前: eba
URL:
> Repository remi is listed more than once in the configuration

私も同じメッセージでUpdateできませんでした。

/etc/yum.repos.d/
 remi-enterprise.repo
 remi.repo

上記の状態で、remiリポジトリが重複していたようでした。
片方を削除してうまくいきました。
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -