このスレッドは未解決です(解決したらこちらで解決済にしてください)
<<戻る

qmailadminの設定がうまくいかないです このメッセージに返信する
日時: 2010/02/21 19:18
名前: じじ
URL:
このサイトを見ながら設定をしております。
qmailadminのインストールを終え、WEB画面を確認しようとすると、
初めの認証の画面は出て、そのまま続行をすると、
「Internet Explorer ではこのページは表示できません」とでてきました。
何回か行ったのですが、どうもうまくいきません。
試してみたのはqmailadmin1.2.9 と 1.2.13です。

どなたかご教示いただけたらと思います。

現状は
http://IPアドレス/ → 表示されます。
https://IPアドレス/ → 表示されます。

http://IPアドレス/cgi-bin/ → Forbiddenと表示
https://IPアドレス/cgi-bin/ → Forbiddenと表示

/var/log/httpd/内の
access_logにはアクセス記録がありました。
error_logには記録がありません。
ssl_access_logにはアクセス記録がありました。
ssl_error_logには記録がありません。

vmwareの設定はできていたのでその辺の・・・認証の設定はできていると思います。

よろしくお願いいたします。
記事編集 編集
Re: qmailadminの設定がうまくいかないです このメッセージに返信する
日時: 2010/02/22 13:55
名前: stranger
URL: http://ja.528p.com/
suexecの問題はありませんか
/var/log/httpd/suexec_logを見てみる
記事編集 編集
Re: qmailadminの設定がうまくいかないです このメッセージに返信する
日時: 2010/02/22 17:42
名前: じじ
URL:
お世話になります。

/var/log/httpd/suexec_log
ですが、中身は空っぽでした。

よろしくお願いします。
記事編集 編集
Re: qmailadminの設定がうまくいかないです このメッセージに返信する
日時: 2010/02/22 19:04
名前: stranger
URL: http://ja.528p.com/
/var/www/cgi-bin/にqmailadminの実行ファイルは存在するのですか?
記事編集 編集
Re: qmailadminの設定がうまくいかないです このメッセージに返信する
日時: 2010/02/22 20:26
名前: じじ
URL:
/var/www/cgi-bin/の中はこのようになっていました。

-rwsr-sr-x 1 vpopmail vchkpw 159076 2月 21 17:59 qmailadmin

ファイルはあるようです。
他、バーチャルドメインでWEBとメールを構築しています。

よろしくお願いします。
記事編集 編集
Re: qmailadminの設定がうまくいかないです このメッセージに返信する
日時: 2010/02/23 08:56
名前: stranger
URL: http://ja.528p.com/
>/var/www/cgi-bin/の中はこのようになっていました。
>
>-rwsr-sr-x 1 vpopmail vchkpw 159076 2月 21 17:59 qmailadmin
>
>ファイルはあるようです。
>他、バーチャルドメインでWEBとメールを構築しています。
>
>よろしくお願いします。
>
http://サーバーIPアドレス/cgi-bin/qmailadmin
でスクリプト名を指定してアクセスしてみる

考えられること
1 逆にapacheのsuexecが有効になっていない
2 apacheのcgi-binの設定に間違いがある
3 selinuxが有効になっていて、拒否されている
など
記事編集 編集
Re: qmailadminの設定がうまくいかないです このメッセージに返信する
日時: 2010/02/24 18:35
名前: じじ
URL:
stranger様の言われるとおり、試してみました。

http://サーバーIPアドレス/cgi-bin/qmailadmin
→で直接アクセスしてみましたが同じく見えませんでした。

1 逆にapacheのsuexecが有効になっていない
→log情報にenableと出ておりましたので有効であると思います。

2 apacheのcgi-binの設定に間違いがある
→本サイトを参考に見返しましたが、間違いは無いようでした。

3 selinuxが有効になっていて、拒否されている
→getenforceで確認すると、disabledで帰ってきました。


色々試していて、本サイトqmailadminページのhttpsアクセス設定を解除(削除)
したところ表示されました。
https://サーバーIPアドレス/だけでアクセスしたところ
認証の画面はできてきますが、通過するとまたURLが
http://サーバーIPアドレス/にもどっていました。

治す方法をお願いします・・・
記事編集 編集
Re: qmailadminの設定がうまくいかないです このメッセージに返信する
日時: 2010/02/25 16:59
名前: じじ
URL:
httpsの件で

>https://サーバーIPアドレス/だけでアクセスしたところ
>認証の画面はできてきますが、通過するとまたURLが
>http://サーバーIPアドレス/にもどっていました。

IPではなく、ドメイン名で外部からアクセスした所、動作いたしました。
詳しく解析しておりませんが、ネームサーバ&バーチャルホストの
からみでそうなっていたのかもしれません。

では話を元に戻して、
httpsアクセス設定は解除させた状態で、

http://ローカルサーバIP/cgi-bin/qmailadmin
とすると表示。

http://ドメイン名/cgi-bin/qmailadmin
とすると表示せず。
グローバルIPでも試しましたがダメでした。

何かおかしなことになっています・・・
この状態でどなたかドメイン名からのアクセスで
表示させる方法をご教授お願いいたします。
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -