このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

mysqlのyumでlibmysqlclient.so.14 このメッセージに返信する
日時: 2009/09/07 11:10
名前: tom
URL: http://centossrv.com/mysql.shtml
 大変お世話になっております。
いつも参考にさせていただいております。

mysqlをインストールしたくて

http://centossrv.com/mysql.shtml

を参考にしてCentOS5.3にmysqlのインストールを試みました。
新規にセットアップしたばかりの綺麗な状態です。

行った手順は

1.http://centossrv.com/centos5-init.shtml
2.http://centossrv.com/cpan2rpm.shtml
3.http://centossrv.com/clamav.shtml

の後

http://centossrv.com/mysql.shtml

を進めますと

[root@webtrsv ~]# yum -y install mysql-server
Loaded plugins: downloadonly, fastestmirror, priorities
Loading mirror speeds from cached hostfile
* rpmforge: apt.sw.be
* base: ftp.oss.eznetsols.org
* updates: ftp.oss.eznetsols.org
* addons: ftp.oss.eznetsols.org
* extras: ftp.oss.eznetsols.org
519 packages excluded due to repository priority protections
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package mysql-server.i386 0:5.0.45-7.el5 set to be updated
--> Processing Dependency: mysql = 5.0.45-7.el5 for package: mysql-server
--> Processing Dependency: perl(DBI) for package: mysql-server
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package: mysql-server
--> Processing Dependency: perl-DBI for package: mysql-server
--> Processing Dependency: libmysqlclient_r.so.15(libmysqlclient_15) for package: mysql-server
--> Processing Dependency: libmysqlclient.so.15 for package: mysql-server
--> Processing Dependency: perl-DBD-MySQL for package: mysql-server
--> Processing Dependency: libmysqlclient_r.so.15 for package: mysql-server
--> Running transaction check
---> Package mysql.i386 0:5.0.45-7.el5 set to be updated
---> Package perl-DBI.i386 0:1.52-2.el5 set to be updated
---> Package perl-DBD-mysql.i386 0:4.012-1.el4.rf set to be updated
--> Processing Dependency: libmysqlclient.so.14 for package: perl-DBD-mysql
--> Processing Dependency: libcrypto.so.4 for package: perl-DBD-mysql
--> Processing Dependency: libssl.so.4 for package: perl-DBD-mysql
--> Processing Dependency: libmysqlclient.so.14(libmysqlclient_14) for package: perl-DBD-mysql
--> Running transaction check
---> Package openssl097a.i386 0:0.9.7a-9.el5_2.1 set to be updated
---> Package perl-DBD-mysql.i386 0:4.012-1.el4.rf set to be updated
--> Processing Dependency: libmysqlclient.so.14 for package: perl-DBD-mysql
--> Processing Dependency: libmysqlclient.so.14(libmysqlclient_14) for package: perl-DBD-mysql
--> Finished Dependency Resolution
perl-DBD-mysql-4.012-1.el4.rf.i386 from rpmforge has depsolving problems
--> Missing Dependency: libmysqlclient.so.14(libmysqlclient_14) is needed by package perl-DBD-mysql-4.012-1.el4.rf.i386 (rpmforge)
perl-DBD-mysql-4.012-1.el4.rf.i386 from rpmforge has depsolving problems
--> Missing Dependency: libmysqlclient.so.14 is needed by package perl-DBD-mysql-4.012-1.el4.rf.i386 (rpmforge)
Error: Missing Dependency: libmysqlclient.so.14 is needed by package perl-DBD-mysql-4.012-1.el4.rf.i386 (rpmforge)
Error: Missing Dependency: libmysqlclient.so.14(libmysqlclient_14) is needed by package perl-DBD-mysql-4.012-1.el4.rf.i386 (rpmforge)
[root@webtrsv ~]#

となり依存関係のエラーが出て前へ進めませんでした。
初心者で大変もうしけございませんが、
どのように対処すればよいかご教授いただけないでしょか。
よろしくお願いいたします。


ちなみに

[root@webtrsv ~]# getdnforce
-bash: getdnforce: command not found
[root@webtrsv ~]# getenforce
Disabled
[root@webtrsv ~]# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
[root@webtrsv ~]#

でございます。




記事編集 編集
Re: mysqlのyumでlibmysqlclient.so.14 このメッセージに返信する
日時: 2009/09/07 11:28
名前: ZED
URL:
ん〜
はじめから、このサイトの通りインストールしてますか?
libmysqlclientを入れれば直るのですが、たまにstartできない自体にもなります。

ちゃんと、
yum grouplist

ちゃんと指定の物が入っているか見れみるといいです。
たとえば、開発ツールが入ってなかったりすることがよくあります。
yum groupinstall "開発ツール"で解決できますが、確認してみて下さい。

記事編集 編集
Re: mysqlのyumでlibmysqlclient.so.14 このメッセージに返信する
日時: 2009/09/07 14:17
名前: stranger
URL: http://ja.528p.com/
rpmforgeの設定が古いのだろう
rpmforge-release-0.3.6-1.el5.rf.i386.rpm
がインストールされているか調べてみる

/etc/yum.repos.d/mirrors-rpmforge
/etc/yum.repos.d/rpmforge.repo

を確認

el4とel5が混在する理由は?
記事編集 編集
Re: mysqlのyumでlibmysqlclient.so.14 このメッセージに返信する
日時: 2009/09/07 14:32
名前: tom
URL: http://centossrv.com/mysql.shtml
stranger様、 ZED様

ご教授ありがとうございました。
ZEDさまに頂いたことを受けて私が勝手にCentOSを
最初からインストールし直してしまいました。

 インストール直後
yum -y update
の後すかさず
yum -y install mysql-server
を実行いたしましたら
Complete!
となり成功してしまいました。

せっかく現象が出たのだから
皆様に頂いたアドバイスを順に検証して
本当の原因を突き止めておきたかったです。

今後は留意いたします。

この度はありがとうございました。

記事編集 編集
Re: mysqlのyumでlibmysqlclient.so.14 このメッセージに返信する
日時: 2009/09/07 14:43
名前: ZED
URL:
>el4とel5が混在する理由は?

というか・・・なぜmysql4を入れたか・・・って話でっすわね。
4系から5系入れると出るメッセージ
記事編集 編集
Re: mysqlのyumでlibmysqlclient.so.14 このメッセージに返信する
日時: 2009/09/07 14:54
名前: stranger
URL:
>>el4とel5が混在する理由は?
>
>というか・・・なぜmysql4を入れたか・・・って話でっすわね。
>4系から5系入れると出るメッセージ

RPMforgeリポジトリ導入の所で
間違ってel4用を入れたんじゃないですか
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -