このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

HAクラスターシステム構築-古いverのカーネルがインストー このメッセージに返信する
日時: 2009/08/07 10:44
名前: nobby
URL: http://wfc.dip.jp/
HAクラスターシステムの構築にトライしていますが、古いカーネルの
インストールでつまづいています。
# yum -y install yum-allowdowngrade
これは特に問題はなかったです。

# yum --allow-downgrade -y install kernel-2.6.18-92.1.13.el5
Loaded plugins: allowdowngrade, fastestmirror, priorities
Loading mirror speeds from cached hostfile
* rpmforge: fr2.rpmfind.net
* base: ftp.riken.jp
* updates: ftp.riken.jp
* addons: ftp.riken.jp
* extras: ftp.riken.jp
396 packages excluded due to repository priority protections
Setting up Install Process
Parsing package install arguments
No package kernel-2.6.18-92.1.13.el5 available.
Nothing to do

ということでkernel-2.6.18-92.1.3.el5が導入できないでいます。どの辺が問題か
御教示願います。

記事編集 編集
Re: HAクラスターシステム構築-古いverのカーネルがインストー このメッセージに返信する
日時: 2009/08/07 11:32
名前: nobby
URL:
自己レスです。標準repositoryの設定は以下のようにしています。

[base]
name=CentOS-$releasever - Base
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os
#baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
priority=1
#released updates
[updates]
name=CentOS-$releasever - Updates
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates
#baseurl=http://mirror.centos.org/centos/$releasever/updates/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
priority=1

#packages used/produced in the build but not released
[addons]
name=CentOS-$releasever - Addons
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=addons
#baseurl=http://mirror.centos.org/centos/$releasever/addons/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
priority=1

#additional packages that may be useful
[extras]
name=CentOS-$releasever - Extras
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=extras
#baseurl=http://mirror.centos.org/centos/$releasever/extras/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
priority=1

#additional packages that extend functionality of existing packages
[centosplus]
name=CentOS-$releasever - Plus
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=centosplus
#baseurl=http://mirror.centos.org/centos/$releasever/centosplus/$basearch/
gpgcheck=1
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5

#contrib - packages by Centos Users
[contrib]
name=CentOS-$releasever - Contrib
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=contrib
#baseurl=http://mirror.centos.org/centos/$releasever/contrib/$basearch/
gpgcheck=1
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5

記事編集 編集
Re: HAクラスターシステム構築-古いverのカーネルがインストー このメッセージに返信する
日時: 2009/08/07 11:48
名前: stranger
URL: http://ja.528p.com/
>ということでkernel-2.6.18-92.1.13.el5が導入できないでいます。どの辺が問題か
リリースバージョンは5.2ですか
上記のkernelは5.2/updateのものですが

手動でインストールされたらどうでしょう
古いkernelが必要な意味がわかりませんので 私はここまで
記事編集 編集
Re: HAクラスターシステム構築-古いverのカーネルがインストー このメッセージに返信する
日時: 2009/08/07 12:04
名前: nobby
URL:
早速のコメント有難うございます。

>リリースバージョンは5.2ですか
>上記のkernelは5.2/updateのものですが

あら、そうだったんですか。現在のKernelは5.3です。

>手動でインストールされたらどうでしょう
>古いkernelが必要な意味がわかりませんので 私はここまで

必要な意味としては、本サイトからの引用では:

DRBDに必要なkmod-drbd82とkernelはバージョンの同期が必要なので、kmod-drbd82対応kernelバージョンを確認し、必要に応じてkmod-drbd82が対応するバージョンのkernelをインストールし、該当バージョンのkernelでシステムを起動する。

となっていますが、本サイトではOSのバージョンは5.2を対象としているということなのでしょう。
記事編集 編集
Re: HAクラスターシステム構築-古いverのカーネルがインストー このメッセージに返信する
日時: 2009/08/07 14:39
名前: stranger
URL: http://ja.528p.com/
>必要な意味としては、本サイトからの引用では:
>
>DRBDに必要なkmod-drbd82とkernelはバージョンの同期が必要なので、kmod-drbd82対応kernelバージョンを確認し、必要に応じてkmod-drbd82が対応するバージョンのkernelをインストールし、該当バージョンのkernelでシステムを起動する。
>
>となっていますが、本サイトではOSのバージョンは5.2を対象としているということなのでしょう。
>
本文中のkernelのバージョンは5.2ですね
kernelバージョンが確認できているのですから
手動でダウンロードして手動でインストールすれば良いのでは?

rpm -ivh --force kernel-2.6.18-92.1.13.el5.i686.rpm

現在のkmod-drbd82に対応するkernelは自分で調べてください
記事編集 編集
Re: HAクラスターシステム構築-古いverのカーネルがインストー このメッセージに返信する
日時: 2009/08/07 15:49
名前: nobby
URL:

>本文中のkernelのバージョンは5.2ですね
>kernelバージョンが確認できているのですから
>手動でダウンロードして手動でインストールすれば良いのでは?
>
>rpm -ivh --force kernel-2.6.18-92.1.13.el5.i686.rpm
>
>現在のkmod-drbd82に対応するkernelは自分で調べてください

kernelを5.2まで落としてこのDRBDを入れる価値は無いと判断し、
自分の環境では別の方法でミラーリング(レプリケーション)を
試してみようと思います。
有難うございました。
記事編集 編集
オークリー サングラス アジアンフィット このメッセージに返信する
日時: 2013/07/31(Wed) 03:34
名前: 061478
URL: http://brandoakleglasses.tumblr.com/
ターニングポイントも久しぶりでよかったけど、ダリ督夫としては、ジョーウォルシュのタイムアウトとジェームステーラーのスチームローラーブルースも今回やりたかった曲でした。今後のレパートリーに入れていくつもりです。新曲も作りますね。それでは完熟トリオで待っとるでよ! オークリー サングラス アジアンフィット http://brandoakleglasses.tumblr.com/
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -