このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

Xenでsambaについて このメッセージに返信する
日時: 2009/06/09 13:18
名前: サンバ
URL:
お世話になっています。
いつもこちらのWebサイトを参考にWebサーバやsambaを構築し自宅で活用しています。

一台の物理マシンにWebサーバとsambaを競合させることはセキュリティー上好ましくないことをこちらで
勉強し、"Xen"でドメインO(管理OS)とドメインU(ゲストOS)に仮想化しました。

ドメインO(管理OS)  192.168.0.20
ドメインU(ゲストOS) 192.168.0.50
IPv4 address: 192.168.0.50____ / 255.255.255.0___
| Gateway: 192.168.0.1______________________________
| Name Server: 192.168.0.1______________________________

インストール完了後、
[root@localhost ~]#xm list
Name                 ID Mem(MiB) VCPUs State Time(s)
CentOS8               11 255 1 -b---- 17.0
Domain-0               0 1500 1 r----- 255.8

#余談:CentOS8とは何回か失敗し、この名前になりました。CentOS5/6/7 が中途半端にインストールされています。
こちらの削除方法もアドバイス頂けたらと思っています。(メモリが無駄になっているかもしれません)

[root@localhost ~]# xm console CentOS8 ← ドメインUコンソールへ接続し、

[root@ゲストOS ~]# yum -y install samba ← sambaインストール
と再度サンバをインストールし適宜設定をした後に、

Windowsから \\192.168.0.50 としましたが残念ながら サンバにアクセス出来ません。

#ドメインO(管理OS)  192.168.0.20 側の サンバは正常にアクセス出来ます。

Xenは初めてです、設定に何か問題がありますでしょうか?
ご指導よろしくお願いします。
記事編集 編集

Page: | 1 | 2 | 3 |

Re: Xenでsambaについて このメッセージに返信する
日時: 2009/06/09 19:15
名前: サンバ
URL:
>XENについての実戦的な説明
>http://www.asahi-net.or.jp/~aa4t-nngk/xen.html
>
>libvirtが勝手にNATを設定するようです
>上記のサイトで”単一の単純ブリッジネットワーク”を参考にする

ありがとうございます。

ZED様同様なのですが、

vi /etc/xen/CentOS5

name = "CentOS5"
uuid = "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
maxmem = 256
memory = 256
vcpus = 1
bootloader = "/usr/bin/pygrub"
on_poweroff = "destroy"
on_reboot = "restart"
on_crash = "restart"
vfb = [ ]
disk = [ "tap:aio:/var/lib/xen/images/CentOS5.img,xvda,w" ]
vif = [ "mac=xx:xx:xx:xx:xx:xx,bridge=xenbr0" ]

と言うように既に xenbr0 変更されているようなのですが?


記事編集 編集
Re: Xenでsambaについて このメッセージに返信する
日時: 2009/06/10 01:42
名前: stranger
URL: http://ja.528p.com/
sysctl -a | grep net.ipv4.ip_forward
net.ipv4.ip_forward = 1 になっていますか

service iptables stop
を実行して iptablesをすべてACCEPTにしてみる
記事編集 編集
Re: Xenでsambaについて このメッセージに返信する
日時: 2009/06/10 03:02
名前: サンバ
URL:
>sysctl -a | grep net.ipv4.ip_forward
>net.ipv4.ip_forward = 1 になっていますか
>
>service iptables stop
>を実行して iptablesをすべてACCEPTにしてみる

ありがとうございます。

[root@localhost ~]# sysctl -a | grep net.ipv4.ip_forward
net.ipv4.ip_forward = 1
[root@localhost ~]# service iptables stop
ファイアウォールルールを適用中: [ OK ]
チェインポリシーを ACCEPT に設定中filter [ OK ]
iptables モジュールを取り外し中 [ OK ]

[root@ゲストOS ~]# service iptables stop
で開きました。ありがとうございます。
管理OS側はサンバのポートを開放しているので、
[root@localhost ~]# service iptables start
でも開けることを確認しました。

単純にゲストOS側のサンバのポート解放の問題だったようです。
誠に申し訳ありません。ありがとうございます。
記事編集 編集

Page: | 1 | 2 | 3 |

件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -