このスレッドは解決済です(未解決に戻す場合はこちら)
<<戻る

AMDのATI純正ドライバ(Linux向け)インストール。 このメッセージに返信する
日時: 2008/11/16 20:06
名前: よっしー
URL: https://takao-y.net/~takao/fswiki/wiki.cgi
こんばんは、お世話になります。

先日来の一連のサーバ構築が本日漸く終わりましたので、
一段落着いたところで、掲題の件につきドライバの
アップデートがてら11月現在で最新の物のインストール
を実行しようとしたところ、パッケージの
/usr/share/ati/fglrx-install.logに下記エラーが記載
されて失敗してしまいました。(;_;)

[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Error] Kernel Module : No kernel module build environment - please consult readme.

上記エラーメッセージに従ってパッケージ添付のFAQ集
を確認したところ、何やら/usr/src配下に現在使用中の
カーネルバージョンのバージョンと一致するシンボリック
リンクが無い為のエラーらしいことは解ったのですが、
具体的にそれ以上の手順を見つけることが出来ませんでした。
/usr/src/配下に/usr/src/kernels配下のカーネルバージョン名
らしきディレクトリとのlinuxという名前のシンボリックリンク
を作ってみたりしましたが結果は同じでした・・・。(;_;)

こうなるとカーネル再構築しかないのでしょうか?
ドライバのインストール手順にはそのような手順を
推奨する記載は見当たらないのですが・・・。

駄スレで大変恐縮ですが、どなたかお分かりになる方が
いらっしゃいましたら宜しくお願い致します。尚、使用
ビデオカードは、ATI RADEON HD2400XTです。また使用
カーネルのバージョンは、2.6.18-92.1.18.el5PAE i686です。

宜しくお願い致します。

以上
記事編集 編集
Re: AMDのATI純正ドライバ(Linux向け)インストール。 このメッセージに返信する
日時: 2008/11/16 20:11
名前: MMM
URL:
他の糞スレ分、解決したんなら質問する前にスレ閉じろ
記事編集 編集
Re: AMDのATI純正ドライバ(Linux向け)インストール。 このメッセージに返信する
日時: 2008/11/16 20:48
名前: よっしー
URL: https://takao-y.net/~takao/fswiki/wiki.cgi
MMMさん>
他のスレ、閉じて置きました。
宜しくお願いします。
記事編集 編集
Re: AMDのATI純正ドライバ(Linux向け)インストール。 このメッセージに返信する
日時: 2008/11/17 06:03
名前: stranger
URL: http://ja.528p.com/
>MMMさん>
留意事項を読みましょう

サーバ環境にGUIが必要なのかどうかは別にして

fglrxの要求するkernelとCentOSにインストールされているkernelの
バージョンを合わせる必要がある

develパッケージをインストールすると
/lib/modules/kernel-xxx
のなかに build sourceのシンボリックリンクが作られ
/usr/src/kernels/kernel-xxxを呼び出す仕組み

普通のソースファイルは
glibc-headersを読みにいくのでkernelソースを読みにいくことはあまりない

最終情報として
どうやったらうまくいったかの報告はしてほしい
「うまくいきました」だけでは、他の人の役にたたない
無償の代償
記事編集 編集
Re: AMDのATI純正ドライバ(Linux向け)インストール。 このメッセージに返信する
日時: 2008/11/23 16:11
名前: よっしー
URL: https://takao-y.net/~takao/fswiki/wiki.cgi
こんばんは、お世話になります。

strangerさん>
上記の件、あれからネットで検索してみたところ、
ご指摘のATIドライバのソースの仕様の為か、
どうもxenカーネルやPAEカーネルでは成功事例が
無い(皆さん、その時点で断念されているようです)
ようでして、また、あまりこれ以上カーネル周り
を弄繰り回してシステムが起動しなくなるのも
考えものですので、取り敢えず当面はvesaドライバ
使用で代替することにしました。

アドバイス、誠に有難う御座いました。

宜しくお願い致します。

以上
記事編集 編集
件名※必須
名前※必須
URL
任意のパスワード (投稿後のコメント修正・削除時に使用)
画像認証※必須 投稿キー(画像で表示されている数字を入力)
コメント※必須

※質問を投稿後に自己解決された場合は、原因と行った対処を具体的に書き込み下さるよう、よろしくお願いします。

- WEB PATIO -